summaryrefslogtreecommitdiffstats
path: root/comm/suite/moz.build
diff options
context:
space:
mode:
Diffstat (limited to 'comm/suite/moz.build')
-rw-r--r--comm/suite/moz.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/comm/suite/moz.build b/comm/suite/moz.build
new file mode 100644
index 0000000000..09ba2b26d1
--- /dev/null
+++ b/comm/suite/moz.build
@@ -0,0 +1,33 @@
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+CONFIGURE_SUBST_FILES += ["installer/Makefile"]
+
+DIRS += [
+ "base",
+ "browser",
+ "components",
+ "editor",
+ "extensions",
+ "locales",
+ "mailnews",
+ "modules",
+ "themes/classic",
+ "themes/modern",
+]
+
+if CONFIG['MOZ_IRC']:
+ DIRS += ['chatzilla']
+
+if CONFIG["MAKENSISU"]:
+ DIRS += ["installer/windows"]
+
+if CONFIG["MOZ_BUNDLED_FONTS"]:
+ DIRS += ["/browser/fonts"]
+
+# app is always last as it packages up the built files on mac.
+DIRS += [
+ "app",
+]