summaryrefslogtreecommitdiffstats
path: root/comm/third_party/libotr/tests/regression/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'comm/third_party/libotr/tests/regression/client/Makefile.am')
-rw-r--r--comm/third_party/libotr/tests/regression/client/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/comm/third_party/libotr/tests/regression/client/Makefile.am b/comm/third_party/libotr/tests/regression/client/Makefile.am
new file mode 100644
index 0000000000..d2b11be132
--- /dev/null
+++ b/comm/third_party/libotr/tests/regression/client/Makefile.am
@@ -0,0 +1,16 @@
+AM_CFLAGS = -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/tests/utils/ \
+ -I$(srcdir) \
+ @LIBGCRYPT_CFLAGS@
+
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+
+LIBOTR=$(top_builddir)/src/libotr.la
+
+noinst_PROGRAMS = client
+
+client_SOURCES = client.c
+client_LDADD = $(LIBTAP) $(LIBOTR) -lpthread @LIBGCRYPT_LIBS@
+
+EXTRA_DIST = otr.key