summaryrefslogtreecommitdiffstats
path: root/dom/webidl/FormDataEvent.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/FormDataEvent.webidl')
-rw-r--r--dom/webidl/FormDataEvent.webidl21
1 files changed, 21 insertions, 0 deletions
diff --git a/dom/webidl/FormDataEvent.webidl b/dom/webidl/FormDataEvent.webidl
new file mode 100644
index 0000000000..100e21c75e
--- /dev/null
+++ b/dom/webidl/FormDataEvent.webidl
@@ -0,0 +1,21 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/form-control-infrastructure.html#the-formdataevent-interface
+ */
+
+[Exposed=Window]
+interface FormDataEvent : Event {
+ constructor(DOMString type, optional FormDataEventInit eventInitDict = {});
+
+ // C++ can't deal with a method called FormData() in the generated code
+ [BinaryName="GetFormData"]
+ readonly attribute FormData formData;
+};
+
+dictionary FormDataEventInit : EventInit {
+ required FormData formData;
+};