summaryrefslogtreecommitdiffstats
path: root/gfx/graphite2/src/moz.build
diff options
context:
space:
mode:
Diffstat (limited to 'gfx/graphite2/src/moz.build')
-rwxr-xr-xgfx/graphite2/src/moz.build35
1 files changed, 35 insertions, 0 deletions
diff --git a/gfx/graphite2/src/moz.build b/gfx/graphite2/src/moz.build
new file mode 100755
index 0000000000..02fb5c3b07
--- /dev/null
+++ b/gfx/graphite2/src/moz.build
@@ -0,0 +1,35 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include("sources.mozbuild")
+
+# This should contain all of the _PUBLIC_HEADERS from files.mk
+EXPORTS.graphite2 += [
+ '../geckoextra/include/GraphiteExtra.h',
+ '../geckoextra/include/GraphiteStructsForRLBox.h',
+ '../include/graphite2/Font.h',
+ '../include/graphite2/Log.h',
+ '../include/graphite2/Segment.h',
+ '../include/graphite2/Types.h',
+]
+
+if CONFIG['CC_TYPE'] in ('clang', 'gcc'):
+ UNIFIED_SOURCES += [
+ 'direct_machine.cpp'
+ ]
+else:
+ UNIFIED_SOURCES += [
+ 'call_machine.cpp'
+ ]
+UNIFIED_SOURCES += graphite_sources
+
+for k, v in graphite_defines:
+ DEFINES[k] = v
+
+# We allow warnings for third-party code that can be updated from upstream.
+AllowCompilerWarnings()
+
+FINAL_LIBRARY = 'gkmedias'