summaryrefslogtreecommitdiffstats
path: root/modules/libjar/test/unit/test_bug589292.js
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libjar/test/unit/test_bug589292.js')
-rw-r--r--modules/libjar/test/unit/test_bug589292.js23
1 files changed, 23 insertions, 0 deletions
diff --git a/modules/libjar/test/unit/test_bug589292.js b/modules/libjar/test/unit/test_bug589292.js
new file mode 100644
index 0000000000..07b43d2973
--- /dev/null
+++ b/modules/libjar/test/unit/test_bug589292.js
@@ -0,0 +1,23 @@
+// Make sure we behave appropriately when asking for content-disposition
+
+const { NetUtil } = ChromeUtils.import("resource://gre/modules/NetUtil.jsm");
+
+const path = "data/test_bug589292.zip";
+
+function run_test() {
+ var spec =
+ "jar:" + Services.io.newFileURI(do_get_file(path)).spec + "!/foo.txt";
+ var channel = NetUtil.newChannel({
+ uri: spec,
+ loadUsingSystemPrincipal: true,
+ });
+ channel.open();
+ try {
+ channel.contentDisposition;
+ Assert.ok(false, "The channel has content disposition?!");
+ } catch (e) {
+ // This is what we want to happen - there's no underlying channel, so no
+ // content-disposition header is available
+ Assert.ok(true, "How are you reading this?!");
+ }
+}