summaryrefslogtreecommitdiffstats
path: root/modules/libjar/test/unit/test_crx.js
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libjar/test/unit/test_crx.js')
-rw-r--r--modules/libjar/test/unit/test_crx.js43
1 files changed, 43 insertions, 0 deletions
diff --git a/modules/libjar/test/unit/test_crx.js b/modules/libjar/test/unit/test_crx.js
new file mode 100644
index 0000000000..7e48c3c893
--- /dev/null
+++ b/modules/libjar/test/unit/test_crx.js
@@ -0,0 +1,43 @@
+/* -*- indent-tabs-mode: nil; js-indent-level: 2 -*- */
+/* vim:set ts=2 sw=2 sts=2 et: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+function wrapInputStream(input) {
+ let nsIScriptableInputStream = Ci.nsIScriptableInputStream;
+ let factory = Cc["@mozilla.org/scriptableinputstream;1"];
+ let wrapper = factory.createInstance(nsIScriptableInputStream);
+ wrapper.init(input);
+ return wrapper;
+}
+
+// Make sure that we can read from CRX files as if they were ZIP files.
+function run_test() {
+ // Note: test_crx_dummy.crx is a dummy crx file created for this test. The
+ // public key and signature fields in the header are both empty.
+ let file = do_get_file("data/test_crx_dummy.crx");
+
+ let zipreader = Cc["@mozilla.org/libjar/zip-reader;1"].createInstance(
+ Ci.nsIZipReader
+ );
+ zipreader.open(file);
+ // do crc stuff
+ function check_archive_crc() {
+ zipreader.test(null);
+ return true;
+ }
+ Assert.ok(check_archive_crc());
+ zipreader.findEntries(null);
+ let stream = wrapInputStream(
+ zipreader.getInputStream("modules/libjar/test/Makefile.in")
+ );
+ let dirstream = wrapInputStream(
+ zipreader.getInputStream("modules/libjar/test/")
+ );
+ zipreader.close();
+ zipreader = null;
+ Cu.forceGC();
+ Assert.ok(!!stream.read(1024).length);
+ Assert.ok(!!dirstream.read(100).length);
+}