summaryrefslogtreecommitdiffstats
path: root/modules/libjar/test/unit/test_not_found.js
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libjar/test/unit/test_not_found.js')
-rw-r--r--modules/libjar/test/unit/test_not_found.js18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/libjar/test/unit/test_not_found.js b/modules/libjar/test/unit/test_not_found.js
new file mode 100644
index 0000000000..90c298e64a
--- /dev/null
+++ b/modules/libjar/test/unit/test_not_found.js
@@ -0,0 +1,18 @@
+// Should report file not found on non-existent files
+
+const { NetUtil } = ChromeUtils.import("resource://gre/modules/NetUtil.jsm");
+const path = "data/test_bug333423.zip";
+
+function run_test() {
+ var spec = "jar:" + Services.io.newFileURI(do_get_file(path)).spec + "!/";
+ var channel = NetUtil.newChannel({
+ uri: spec + "file_that_isnt_in.archive",
+ loadUsingSystemPrincipal: true,
+ });
+ try {
+ channel.open();
+ do_throw("Failed to report that file doesn't exist");
+ } catch (e) {
+ Assert.ok(e.name == "NS_ERROR_FILE_NOT_FOUND");
+ }
+}