summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/conformance-checkers/html/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/conformance-checkers/html/Makefile')
-rw-r--r--testing/web-platform/tests/conformance-checkers/html/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/web-platform/tests/conformance-checkers/html/Makefile b/testing/web-platform/tests/conformance-checkers/html/Makefile
new file mode 100644
index 0000000000..332591348f
--- /dev/null
+++ b/testing/web-platform/tests/conformance-checkers/html/Makefile
@@ -0,0 +1,20 @@
+PYTHON=python
+PYTHONFLAGS=
+META_EXTENSIONS=http://help.whatwg.org/extensions/meta-name/
+CURL=curl
+CURLFLAGS=
+PYTHON=python
+PYTHONFLAGS=
+
+.PHONY: ins-del-datetime .FORCE
+
+all: ins-del-datetime tools/meta-extensions elements/meta/names-registered-isvalid.html
+
+ins-del-datetime: tools/ins-del-datetime.py
+ $(PYTHON) $(PYTHONFLAGS) $<
+
+tools/meta-extensions: .FORCE
+ $(CURL) $(CURLFLAGS) $(META_EXTENSIONS) > $@
+
+elements/meta/names-registered-isvalid.html: .FORCE
+ $(PYTHON) $(PYTHONFLAGS) tools/meta-name.py