summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/speculation-rules/prerender/navigator-plugins.tentative.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/speculation-rules/prerender/navigator-plugins.tentative.html')
-rw-r--r--testing/web-platform/tests/speculation-rules/prerender/navigator-plugins.tentative.html52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/web-platform/tests/speculation-rules/prerender/navigator-plugins.tentative.html b/testing/web-platform/tests/speculation-rules/prerender/navigator-plugins.tentative.html
new file mode 100644
index 0000000000..192d4b3cd1
--- /dev/null
+++ b/testing/web-platform/tests/speculation-rules/prerender/navigator-plugins.tentative.html
@@ -0,0 +1,52 @@
+<!DOCTYPE html>
+<!--
+Note that `navigator.plugins` attribute is outdated in the HTML but we
+keep this test until major browsers actually stop supporting it.
+https://html.spec.whatwg.org/C/#dom-navigator-plugins
+-->
+<title>Same-origin prerendering can access navigator.plugins</title>
+<meta name="timeout" content="long">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="/common/utils.js"></script>
+<script src="/speculation-rules/prerender/resources/utils.js"></script>
+<body>
+<script>
+
+setup(() => {
+ assertSpeculationRulesIsSupported();
+ assert_implements_optional(
+ 'plugins' in navigator, 'navigator.plugins is not provided.'
+ );
+});
+
+promise_test(async t => {
+ const uid = token();
+ const bc = new PrerenderChannel('prerender-channel', uid);
+ t.add_cleanup(_ => bc.close());
+
+ const gotMessage = new Promise(resolve => {
+ bc.addEventListener('message', e => {
+ resolve(e.data);
+ }, {
+ once: true
+ });
+ });
+
+ // Start prerendering a page that attempts to access the navigator.plugins.
+ startPrerendering(`resources/navigator-plugins.html?uid=${uid}`);
+ const result = await gotMessage;
+ const plugins = JSON.parse(result);
+ assert_equals(plugins.length, navigator.plugins.length);
+ for (let i = 0; i < plugins.length; ++i) {
+ const expected_plugin = navigator.plugins[i];
+ assert_equals(plugins[i].pluginLength, expected_plugin.length);
+ for (let j = 0; j < plugins[i].pluginLength; ++j) {
+ assert_equals(plugins[i].pluginTypes[j], expected_plugin[j].type,
+ `type of navigator.plugins[${i}].plugin[${j}]`);
+ }
+ }
+}, 'prerendering page should be able to access the navigator.plugins');
+
+</script>
+</body>