summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/getallresponseheaders-status.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/getallresponseheaders-status.htm')
-rw-r--r--testing/web-platform/tests/xhr/getallresponseheaders-status.htm33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/getallresponseheaders-status.htm b/testing/web-platform/tests/xhr/getallresponseheaders-status.htm
new file mode 100644
index 0000000000..a02ab45745
--- /dev/null
+++ b/testing/web-platform/tests/xhr/getallresponseheaders-status.htm
@@ -0,0 +1,33 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: getAllResponseHeaders() excludes status</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#dom-xmlhttprequest-getallresponseheaders" data-tested-assertations="/following::OL[1]/LI[1] /following::OL[1]/LI[3]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ async_test(function() {
+ var client = new XMLHttpRequest()
+ assert_equals(client.getAllResponseHeaders(), "")
+
+ client.onreadystatechange = this.step_func(function() {
+ var headers = client.getAllResponseHeaders().toLowerCase()
+ if(client.readyState == 1) {
+ assert_equals(headers, "")
+ }
+ if(client.readyState > 1) {
+ assert_false(headers.indexOf("200 ok") != -1)
+ assert_false(headers.indexOf("http/1.") != -1)
+ }
+ if(client.readyState == 4)
+ this.done()
+ })
+ client.open("GET", "resources/headers.py")
+ client.send(null)
+ })
+ </script>
+ </body>
+</html>