summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-method-bogus.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-method-bogus.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-method-bogus.htm28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-method-bogus.htm b/testing/web-platform/tests/xhr/open-method-bogus.htm
new file mode 100644
index 0000000000..13bb18bf5c
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-method-bogus.htm
@@ -0,0 +1,28 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() - bogus methods</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[4]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ function method(method) {
+ test(function() {
+ var client = new XMLHttpRequest()
+ assert_throws_dom("SyntaxError", function() { client.open(method, "...") })
+ }, document.title + " (" + method + ")")
+ }
+ method("")
+ method(">")
+ method(" GET")
+ method("G T")
+ method("@GET")
+ method("G:ET")
+ method("GET?")
+ method("GET\n")
+ </script>
+ </body>
+</html>