summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-method-case-insensitive.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-method-case-insensitive.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-method-case-insensitive.htm29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-method-case-insensitive.htm b/testing/web-platform/tests/xhr/open-method-case-insensitive.htm
new file mode 100644
index 0000000000..103381745a
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-method-case-insensitive.htm
@@ -0,0 +1,29 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() - case-insensitive methods test</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol/li[5]" />
+
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ function method(method) {
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.open(method, "resources/content.py", false)
+ client.send(null)
+ assert_equals(client.getResponseHeader("x-request-method"), method.toUpperCase())
+ }, document.title + " (" + method.toUpperCase() + ")")
+ }
+ method("deLETE")
+ method("get")
+ method("heAd")
+ method("OpTIOns")
+ method("post")
+ method("Put")
+ </script>
+ </body>
+</html>