summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-method-case-sensitive.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-method-case-sensitive.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-method-case-sensitive.htm31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-method-case-sensitive.htm b/testing/web-platform/tests/xhr/open-method-case-sensitive.htm
new file mode 100644
index 0000000000..270e32d67a
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-method-case-sensitive.htm
@@ -0,0 +1,31 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() - case-sensitive methods test</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol/li[5]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ function method(method) {
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.open(method, "resources/content.py", false)
+ client.send(null)
+ assert_equals(client.getResponseHeader("x-request-method"), method)
+ }, document.title + " (" + method + ")")
+ }
+ method("XUNICORN")
+ method("xUNIcorn")
+ method("chiCKEN")
+ method("PATCH")
+ method("patCH")
+ method("copy")
+ method("COpy")
+ method("inDEX")
+ method("movE")
+ </script>
+ </body>
+</html>