summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-method-insecure.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-method-insecure.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-method-insecure.htm29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-method-insecure.htm b/testing/web-platform/tests/xhr/open-method-insecure.htm
new file mode 100644
index 0000000000..a6bf442248
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-method-insecure.htm
@@ -0,0 +1,29 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() - "insecure" methods</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol/li[5] following::ol/li[6]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ function method(method) {
+ test(function() {
+ var client = new XMLHttpRequest()
+ assert_throws_dom("SecurityError", function() { client.open(method, "...") })
+ }, document.title + " (" + method + ")")
+ }
+ method("track")
+ method("TRACK")
+ method("trAck")
+ method("TRACE")
+ method("trace")
+ method("traCE")
+ method("connect")
+ method("CONNECT")
+ method("connECT")
+ </script>
+ </body>
+</html>