summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-method-responsetype-set-sync.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-method-responsetype-set-sync.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-method-responsetype-set-sync.htm32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-method-responsetype-set-sync.htm b/testing/web-platform/tests/xhr/open-method-responsetype-set-sync.htm
new file mode 100644
index 0000000000..7858c91409
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-method-responsetype-set-sync.htm
@@ -0,0 +1,32 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() sync request not allowed if responseType is set</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[10]" />
+
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ // Note: the case of calling synchronous open() first, and then setting
+ // responseType, is tested in responsetype.html.
+ function request(type) {
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.onreadystatechange = this.step_func(function(){
+ assert_unreached('No events should fire here')
+ })
+ client.responseType = type
+ assert_throws_dom("InvalidAccessError", function() { client.open('GET', "...", false) })
+ }, document.title + " (" + type + ")")
+ }
+ request("arraybuffer")
+ request("blob")
+ request("json")
+ request("text")
+ request("document")
+ </script>
+ </body>
+</html>