summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-url-base-inserted.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-url-base-inserted.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-url-base-inserted.htm24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-url-base-inserted.htm b/testing/web-platform/tests/xhr/open-url-base-inserted.htm
new file mode 100644
index 0000000000..69ad6193d8
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-url-base-inserted.htm
@@ -0,0 +1,24 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() resolving URLs - insert &lt;base></title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol/li[2]/ol/li[2] following::ol/li[7] following::ol/li[14]/ul/li[2]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-responsetext-attribute" data-tested-assertations="following::ol/li[4]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ test(function() {
+ var client = new XMLHttpRequest(),
+ base = document.createElement("base")
+ base.href = location.href.replace(/\/[^/]*$/, '') + "/resources/"
+ document.getElementsByTagName("head")[0].appendChild(base)
+ client.open("GET", "folder.txt", false)
+ client.send(null)
+ assert_equals(client.responseText, "bottom\n")
+ })
+ </script>
+ </body>
+</html>