summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-url-base.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-url-base.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-url-base.htm22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-url-base.htm b/testing/web-platform/tests/xhr/open-url-base.htm
new file mode 100644
index 0000000000..3c0e8c99d5
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-url-base.htm
@@ -0,0 +1,22 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() resolving URLs - &lt;base></title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <base href="./resources/">
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol/li[2]/ol/li[2] following::ol/li[7] following::ol/li[14]/ul/li[2]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-responsetext-attribute" data-tested-assertations="following::ol/li[4]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.open("GET", "folder.txt", false)
+ client.send(null)
+ assert_equals(client.responseText, "bottom\n")
+ })
+ </script>
+ </body>
+</html>