summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-url-multi-window.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-url-multi-window.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-url-multi-window.htm31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-url-multi-window.htm b/testing/web-platform/tests/xhr/open-url-multi-window.htm
new file mode 100644
index 0000000000..347f4b7e59
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-url-multi-window.htm
@@ -0,0 +1,31 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() resolving URLs (multi-Window; 1)</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[2]/ol[1]/li[2] following::ol[1]/li[7] following::ol[1]/li[14]/ul/li[2]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ var test = async_test()
+ function init() {
+ test.step(function() {
+ var client = new self[0].XMLHttpRequest()
+ client.onreadystatechange = function() {
+ test.step(function() {
+ if(client.readyState == 4) {
+ assert_equals(client.responseText, "bottom\n")
+ test.done()
+ }
+ })
+ }
+ client.open("GET", "folder.txt")
+ client.send("")
+ })
+ }
+ </script>
+ <iframe src="resources/init.htm"></iframe>
+ </body>
+</html>