summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/open-user-password-non-same-origin.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/open-user-password-non-same-origin.htm')
-rw-r--r--testing/web-platform/tests/xhr/open-user-password-non-same-origin.htm25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/open-user-password-non-same-origin.htm b/testing/web-platform/tests/xhr/open-user-password-non-same-origin.htm
new file mode 100644
index 0000000000..e49888cd49
--- /dev/null
+++ b/testing/web-platform/tests/xhr/open-user-password-non-same-origin.htm
@@ -0,0 +1,25 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>XMLHttpRequest: open() - user/pass argument and non same-origin URL doesn't throw</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol/li[9]/ol/li[1] following::ol/li[9]/ol/li[2] following::ol/li[15]/ol/li[1]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ var m = "GET",
+ u = "http://test2.w3.org/",
+ a = false
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.open(m, u, a, "x")
+ assert_equals(client.readyState, 1, "open() was successful - 1")
+ var client2 = new XMLHttpRequest()
+ client2.open(m, u, a, "x", "x")
+ assert_equals(client2.readyState, 1, "open() was successful - 2")
+ })
+ </script>
+ </body>
+</html>