summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/response-invalid-responsetype.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/response-invalid-responsetype.htm')
-rw-r--r--testing/web-platform/tests/xhr/response-invalid-responsetype.htm38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/response-invalid-responsetype.htm b/testing/web-platform/tests/xhr/response-invalid-responsetype.htm
new file mode 100644
index 0000000000..603c4cd0ed
--- /dev/null
+++ b/testing/web-platform/tests/xhr/response-invalid-responsetype.htm
@@ -0,0 +1,38 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: response is plain text if responseType is set to an invalid string</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-response-attribute" data-tested-assertations="following::dd[2]/ol[1]/li[2]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-responsetype-attribute" data-tested-assertations="following::ol[1]/li[4]" /><!-- Not quite - but this is handled in WebIDL, not the XHR spec -->
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ function request(type) {
+ var test = async_test(document.title+' ('+type+')')
+ test.step(function() {
+ var client = new XMLHttpRequest()
+ client.responseType = type
+ assert_equals(client.responseType, '')
+ client.open("GET", "resources/folder.txt", true)
+ client.onload = function(){
+ test.step(function(){
+ assert_equals(client.responseType, '')
+ assert_equals(client.response, 'bottom\n')
+ assert_equals(typeof client.response, 'string')
+ test.done()
+ })
+ }
+ client.send(null)
+ })
+ }
+ request("arrayBuffer") // case sensitive
+ request("JSON") // case sensitive
+ request("glob")
+ request("txt")
+ request("text/html")
+ </script>
+ </body>
+</html>