summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/send-authentication-basic-cors-not-enabled.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/send-authentication-basic-cors-not-enabled.htm')
-rw-r--r--testing/web-platform/tests/xhr/send-authentication-basic-cors-not-enabled.htm28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/send-authentication-basic-cors-not-enabled.htm b/testing/web-platform/tests/xhr/send-authentication-basic-cors-not-enabled.htm
new file mode 100644
index 0000000000..2e7cbaf034
--- /dev/null
+++ b/testing/web-platform/tests/xhr/send-authentication-basic-cors-not-enabled.htm
@@ -0,0 +1,28 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: send() - "Basic" authenticated CORS requests with user name and password passed to open() (asserts failure)</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <script src="/common/utils.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[9]/ol[1]/li[1] following::ol[1]/li[9]/ol[1]/li[2]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-send()-method" data-tested-assertations="following::code[contains(@title,'http-authorization')]/.." />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ test(function() {
+ var client = new XMLHttpRequest(),
+ urlstart = 'www1.'+location.host + location.pathname.replace(/\/[^\/]*$/, '/')
+ client.withCredentials = true
+ user = token()
+ client.open("GET", location.protocol+'//'+urlstart + "resources/auth10/auth.py", false, user, 'pass')
+ client.setRequestHeader("x-user", user)
+ assert_throws_dom("NetworkError", function(){ client.send(null) })
+ assert_equals(client.responseText, '')
+ assert_equals(client.status, 0)
+ assert_equals(client.getResponseHeader('x-challenge'), null)
+ }, document.title)
+ </script>
+ </body>
+</html>