summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/send-entity-body-basic.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/send-entity-body-basic.htm')
-rw-r--r--testing/web-platform/tests/xhr/send-entity-body-basic.htm28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/send-entity-body-basic.htm b/testing/web-platform/tests/xhr/send-entity-body-basic.htm
new file mode 100644
index 0000000000..526a1fb349
--- /dev/null
+++ b/testing/web-platform/tests/xhr/send-entity-body-basic.htm
@@ -0,0 +1,28 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: send() - data argument</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-send()-method" data-tested-assertations="/following::ol/li[4]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ function request(input, output) {
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.open("POST", "resources/content.py", false)
+ client.send(input)
+ assert_equals(client.responseText, output)
+ }, document.title + " (" + output + ")")
+ }
+ request(1, "1")
+ request(10000000, "10000000")
+ request([2,2], "2,2")
+ request(false, "false")
+ request("A\0A", "A\0A")
+ request(new URLSearchParams([[1, 2], [3, 4]]), "1=2&3=4")
+ </script>
+ </body>
+</html>