summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/send-entity-body-empty.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/send-entity-body-empty.htm')
-rw-r--r--testing/web-platform/tests/xhr/send-entity-body-empty.htm26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/send-entity-body-empty.htm b/testing/web-platform/tests/xhr/send-entity-body-empty.htm
new file mode 100644
index 0000000000..f307e77809
--- /dev/null
+++ b/testing/web-platform/tests/xhr/send-entity-body-empty.htm
@@ -0,0 +1,26 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: send("") - empty entity body</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-send()-method" data-tested-assertations="following::ol[1]/li[7]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#dom-XMLHttpRequest-send-a-string" data-tested-assertations="following::p[1] following::p[2] following::p[3]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ function request(method) {
+ var client = new XMLHttpRequest()
+ client.open(method, "resources/content.py", false)
+ client.upload.onloadstart = function(){assert_unreached('this event should not fire for empty strings')}
+ client.send("")
+ var expectedLength = method == "HEAD" ? "NO" : "0";
+ assert_equals(client.getResponseHeader("x-request-content-length"), expectedLength)
+ }
+ test(function() { request("POST"); }, document.title + " (POST)");
+ test(function() { request("PUT"); }, document.title + " (PUT)");
+ test(function() { request("HEAD"); }, document.title + " (HEAD)");
+ </script>
+ </body>
+</html>