summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/send-network-error-sync-events.sub.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/send-network-error-sync-events.sub.htm')
-rw-r--r--testing/web-platform/tests/xhr/send-network-error-sync-events.sub.htm45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/send-network-error-sync-events.sub.htm b/testing/web-platform/tests/xhr/send-network-error-sync-events.sub.htm
new file mode 100644
index 0000000000..2266eb36e1
--- /dev/null
+++ b/testing/web-platform/tests/xhr/send-network-error-sync-events.sub.htm
@@ -0,0 +1,45 @@
+<!DOCTYPE html>
+<html>
+<head>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#infrastructure-for-the-send()-method" data-tested-assertations="following::dt[4] following::dd[4]/p" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#network-error" data-tested-assertations=".." />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#request-error" data-tested-assertations="following::ol[1]/li[4] following::ol[1]/li[5]" />
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <title>XMLHttpRequest: The send() method: Throw a "throw an "NetworkError" exception when Network error happens (synchronous flag is set)</title>
+</head>
+
+<body>
+ <div id="log"></div>
+
+ <script type="text/javascript">
+ test(function()
+ {
+ var xhr = new XMLHttpRequest();
+
+ xhr.open("POST", "http://nonexistent.{{host}}:{{ports[http][0]}}", false);
+
+ assert_throws_dom("NetworkError", function()
+ {
+ xhr.send("Test Message");
+ });
+ assert_equals(xhr.readyState, 4)
+
+ }, "http URL");
+
+ test(function()
+ {
+ var xhr = new XMLHttpRequest();
+
+ xhr.open("GET", "data:text/html;charset=utf-8;base64,PT0NUWVBFIGh0bWw%2BDQo8", false);
+
+ assert_throws_dom("NetworkError", function()
+ {
+ xhr.send("Test Message");
+ });
+ assert_equals(xhr.readyState, 4)
+
+ }, "data URL");
+ </script>
+</body>
+</html>