summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/sync-xhr-supported-by-feature-policy.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/sync-xhr-supported-by-feature-policy.html')
-rw-r--r--testing/web-platform/tests/xhr/sync-xhr-supported-by-feature-policy.html11
1 files changed, 11 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/sync-xhr-supported-by-feature-policy.html b/testing/web-platform/tests/xhr/sync-xhr-supported-by-feature-policy.html
new file mode 100644
index 0000000000..45588bf6af
--- /dev/null
+++ b/testing/web-platform/tests/xhr/sync-xhr-supported-by-feature-policy.html
@@ -0,0 +1,11 @@
+<!DOCTYPE html>
+<title>Test that sync-xhr is advertised in the feature list</title>
+<link rel="help" href="https://w3c.github.io/webappsec-feature-policy/#dom-featurepolicy-features">
+<link rel="help" href="https://xhr.spec.whatwg.org/#feature-policy-integration">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+test(() => {
+ assert_in_array('sync-xhr', document.featurePolicy.features());
+}, 'document.featurePolicy.features should advertise sync-xhr.');
+</script>