summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/timeout-sync.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/timeout-sync.htm')
-rw-r--r--testing/web-platform/tests/xhr/timeout-sync.htm25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/timeout-sync.htm b/testing/web-platform/tests/xhr/timeout-sync.htm
new file mode 100644
index 0000000000..d8b2cc48f3
--- /dev/null
+++ b/testing/web-platform/tests/xhr/timeout-sync.htm
@@ -0,0 +1,25 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: timeout not allowed for sync requests</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-timeout-attribute" data-tested-assertations="following::ol/li[1]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol/li[10]" />
+ </head>
+ <body>
+ <div id="log"></div>
+ <script>
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.open('GET', 'folder.txt', false)
+ assert_throws_dom("InvalidAccessError", function() { client.timeout = 1000 })
+ }, 'setting timeout attribute on sync request')
+ test(function() {
+ var client = new XMLHttpRequest()
+ client.timeout = 1000
+ assert_throws_dom("InvalidAccessError", function() { client.open('GET', 'folder.txt', false) })
+ }, 'open() with async false when timeout is set')
+ </script>
+ </body>
+</html>