summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/xmlhttprequest-timeout-synconmain.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/xmlhttprequest-timeout-synconmain.html')
-rw-r--r--testing/web-platform/tests/xhr/xmlhttprequest-timeout-synconmain.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/xmlhttprequest-timeout-synconmain.html b/testing/web-platform/tests/xhr/xmlhttprequest-timeout-synconmain.html
new file mode 100644
index 0000000000..eb9ecb75a0
--- /dev/null
+++ b/testing/web-platform/tests/xhr/xmlhttprequest-timeout-synconmain.html
@@ -0,0 +1,23 @@
+ <!DOCTYPE html>
+<html>
+<head>
+ <meta charset="utf-8" />
+ <title>XHR2 Timeout Property Tests</title>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-timeout-attribute" data-tested-assertations="following::ol[1]/li[1]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[10]" />
+ <meta name=timeout content=long>
+ <meta name=variant content="?timeout after open">
+ <meta name=variant content="?timeout before open">
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <script src="resources/xmlhttprequest-timeout.js"></script>
+ <script src="resources/xmlhttprequest-timeout-runner.js"></script>
+</head>
+<body>
+ <h1>Description</h1>
+ <p>This test validates that the XHR2 timeout property behaves as expected in async cases in document (i.e. non-worker) context.</p>
+ <div id="log"></div>
+ <script src="resources/xmlhttprequest-timeout-synconmain.js" type="text/javascript"></script>
+</body>
+</html>
+