summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/xmlhttprequest-timeout-worker-twice.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/xmlhttprequest-timeout-worker-twice.html')
-rw-r--r--testing/web-platform/tests/xhr/xmlhttprequest-timeout-worker-twice.html29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/xmlhttprequest-timeout-worker-twice.html b/testing/web-platform/tests/xhr/xmlhttprequest-timeout-worker-twice.html
new file mode 100644
index 0000000000..f9ad25a50b
--- /dev/null
+++ b/testing/web-platform/tests/xhr/xmlhttprequest-timeout-worker-twice.html
@@ -0,0 +1,29 @@
+ <!DOCTYPE html>
+<html>
+<head>
+ <meta charset="utf-8" />
+ <title>XHR2 Timeout Property Tests in Worker</title>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-timeout-attribute" data-tested-assertations="following::ol[1]/li[2]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#handler-xhr-ontimeout" data-tested-assertations="../.."/>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#timeout-error" data-tested-assertations=".."/>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#request-error" data-tested-assertations="following::ol[1]/li[9]"/>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#infrastructure-for-the-send()-method" data-tested-assertations="following-sibling::dl//code[contains(@title,'dom-XMLHttpRequest-timeout')]/.. following-sibling::dl//code[contains(@title,'dom-XMLHttpRequest-timeout')]/../following-sibling::dd following::dt[1] following::dd[1]" />
+ <meta name=timeout content=long>
+ <meta name=variant content="?load fires normally with no timeout set, twice">
+ <meta name=variant content="?load fires normally with same timeout set twice">
+ <meta name=variant content="?timeout fires normally with same timeout set twice">
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <script src="resources/xmlhttprequest-timeout-runner.js"></script>
+</head>
+<body>
+ <h1>Description</h1>
+ <p>This test validates that the XHR2 timeout property behaves as expected in in a worker context.</p>
+ <div id="log"></div>
+ <script type="text/javascript">
+ var worker = new Worker("resources/xmlhttprequest-timeout-twice.js" + location.search);
+ worker.addEventListener("message", testResultCallbackHandler);
+ </script>
+</body>
+</html>
+