summaryrefslogtreecommitdiffstats
path: root/debian/policy/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 08:50:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 08:50:33 +0000
commit1333020b904a8714d01f4ae4789c5070e8ff90f2 (patch)
tree338ef4570c790f46661f010deeebaaecc58c9bbc /debian/policy/Makefile
parentAdding upstream version 2:9.0.1378. (diff)
downloadvim-1333020b904a8714d01f4ae4789c5070e8ff90f2.tar.xz
vim-1333020b904a8714d01f4ae4789c5070e8ff90f2.zip
Adding debian version 2:9.0.1378-2.debian/2%9.0.1378-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/policy/Makefile')
-rw-r--r--debian/policy/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/policy/Makefile b/debian/policy/Makefile
new file mode 100644
index 0000000..e5d7311
--- /dev/null
+++ b/debian/policy/Makefile
@@ -0,0 +1,23 @@
+
+NULL =
+INSTALL_STUFF = \
+ vim-policy.html/ \
+ vim-policy.txt \
+ $(NULL)
+
+all: html text
+
+html: vim-policy.html/index.html
+text: vim-policy.txt
+
+export LC_ALL=C.UTF-8
+
+vim-policy.html/index.html: vim-policy.xml *.xml
+ docbook2html $< -o $(dir $@)
+vim-policy.txt: vim-policy.xml *.xml
+ docbook2txt $<
+
+clean:
+ $(RM) -rf $(INSTALL_STUFF)
+
+.PHONY: html text