summaryrefslogtreecommitdiffstats
path: root/runtime/indent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/indent/Makefile')
-rw-r--r--runtime/indent/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/runtime/indent/Makefile b/runtime/indent/Makefile
new file mode 100644
index 0000000..f6c4473
--- /dev/null
+++ b/runtime/indent/Makefile
@@ -0,0 +1,14 @@
+# Portable Makefile for running indent tests.
+
+VIM = vim
+VIMRUNTIME = ..
+
+# Run the tests that didn't run yet or failed previously.
+# If a test succeeds a testdir/*.out file will be written.
+# If a test fails a testdir/*.fail file will be written.
+test:
+ VIMRUNTIME=$(VIMRUNTIME) $(VIM) --clean --not-a-term -u testdir/runtest.vim
+
+
+clean testclean:
+ rm -f testdir/*.fail testdir/*.out