summaryrefslogtreecommitdiffstats
path: root/src/VBox/Frontends/VBoxFB/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 16:49:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 16:49:04 +0000
commit16f504a9dca3fe3b70568f67b7d41241ae485288 (patch)
treec60f36ada0496ba928b7161059ba5ab1ab224f9d /src/VBox/Frontends/VBoxFB/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-upstream.tar.xz
virtualbox-upstream.zip
Adding upstream version 7.0.6-dfsg.upstream/7.0.6-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/VBox/Frontends/VBoxFB/Makefile.kmk52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/VBox/Frontends/VBoxFB/Makefile.kmk b/src/VBox/Frontends/VBoxFB/Makefile.kmk
new file mode 100644
index 00000000..17e7efa1
--- /dev/null
+++ b/src/VBox/Frontends/VBoxFB/Makefile.kmk
@@ -0,0 +1,52 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for VBoxFB.
+#
+
+#
+# Copyright (C) 2006-2022 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+PROGRAMS += VBoxFB
+
+#
+# VBoxFB
+#
+VBoxFB_TEMPLATE = VBOXR3NPEXE
+VBoxFB_SOURCES = \
+ VBoxFB.cpp \
+ Framebuffer.cpp \
+ Helper.cpp
+VBoxFB_CXXFLAGS = -Wno-non-virtual-dtor -fshort-wchar
+ifdef VBOX_WITH_XPCOM_NAMESPACE_CLEANUP
+ VBoxFB_DEFS += VBOX_WITH_XPCOM_NAMESPACE_CLEANUP
+endif
+VBoxFB_INCS = $(VBOX_XPCOM_INCS) /usr/include/directfb
+VBoxFB_LIBPATH = $(LIBPATH_XPCOM)
+VBoxFB_LIBS = $(LIB_XPCOM) $(LIB_RUNTIME) directfb
+VBoxFB_DEPS = $(VBOX_PATH_SDK)/bindings/xpcom/include/VirtualBox_XPCOM.h
+
+# generate rules.
+include $(FILE_KBUILD_SUB_FOOTER)
+