summaryrefslogtreecommitdiffstats
path: root/src/libs/xpcom18a4/nsprpub/pkg
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/Makefile.in58
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/linux/Makefile.in44
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/linux/sun-nspr.spec122
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.com32
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.in60
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.targ40
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/Makefile.in22
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/depend27
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/pkginfo.tmpl34
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_com31
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_i38630
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_sparc33
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/Makefile.in22
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/depend30
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/pkginfo.tmpl35
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_com28
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_sparc35
-rwxr-xr-xsrc/libs/xpcom18a4/nsprpub/pkg/solaris/bld_awk_pkginfo.ksh105
-rw-r--r--src/libs/xpcom18a4/nsprpub/pkg/solaris/common_files/copyright28
19 files changed, 816 insertions, 0 deletions
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/Makefile.in b/src/libs/xpcom18a4/nsprpub/pkg/Makefile.in
new file mode 100644
index 00000000..b21d7741
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/Makefile.in
@@ -0,0 +1,58 @@
+#
+# ***** BEGIN LICENSE BLOCK *****
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
+#
+# The contents of this file are subject to the Mozilla Public License Version
+# 1.1 (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+# http://www.mozilla.org/MPL/
+#
+# Software distributed under the License is distributed on an "AS IS" basis,
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
+# for the specific language governing rights and limitations under the
+# License.
+#
+# The Original Code is the Netscape Portable Runtime (NSPR).
+#
+# The Initial Developer of the Original Code is
+# Netscape Communications Corporation.
+# Portions created by the Initial Developer are Copyright (C) 1998-2000
+# the Initial Developer. All Rights Reserved.
+#
+# Contributor(s):
+#
+# Alternatively, the contents of this file may be used under the terms of
+# either the GNU General Public License Version 2 or later (the "GPL"), or
+# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
+# in which case the provisions of the GPL or the LGPL are applicable instead
+# of those above. If you wish to allow use of your version of this file only
+# under the terms of either the GPL or the LGPL, and not to allow others to
+# use your version of this file under the terms of the MPL, indicate your
+# decision by deleting the provisions above and replace them with the notice
+# and other provisions required by the GPL or the LGPL. If you do not delete
+# the provisions above, a recipient may use your version of this file under
+# the terms of any one of the MPL, the GPL or the LGPL.
+#
+# ***** END LICENSE BLOCK *****
+
+#! gmake
+
+MOD_DEPTH = ..
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+include $(MOD_DEPTH)/config/autoconf.mk
+
+DIRS =
+ifeq ($(OS_TARGET),Linux)
+DIRS = linux
+endif
+ifeq ($(OS_TARGET),SunOS)
+DIRS = solaris
+endif
+
+publish::
+ +$(LOOP_OVER_DIRS)
+
+include $(topsrcdir)/config/rules.mk
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/linux/Makefile.in b/src/libs/xpcom18a4/nsprpub/pkg/linux/Makefile.in
new file mode 100644
index 00000000..630af186
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/linux/Makefile.in
@@ -0,0 +1,44 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: Makefile.in $"
+#
+
+MOD_DEPTH = ../..
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+NAME = sun-nspr
+RELEASE = 1
+TOPDIR = /usr/src/redhat
+VERSION = `grep PR_VERSION $(dist_includedir)/prinit.h \
+ | sed -e 's/"$$//' -e 's/.*"//' -e 's/ .*//'`
+
+include $(MOD_DEPTH)/config/autoconf.mk
+
+publish:
+ $(MAKE) clean
+ mkdir -p usr/lib/mps
+ cp -L $(MOD_DEPTH)/dist/lib/* usr/lib/mps
+ mkdir -p usr/include/mps
+ cp -Lr $(MOD_DEPTH)/dist/include/* usr/include/mps
+ tar czvf $(NAME)-$(VERSION).tar.gz usr
+ echo "%define name $(NAME)" >$(NAME).spec
+ echo "%define version $(VERSION)" >>$(NAME).spec
+ echo "%define release $(RELEASE)" >>$(NAME).spec
+
+ cat $(srcdir)/$(NAME).spec >>$(NAME).spec
+ cp $(NAME)-$(VERSION).tar.gz $(TOPDIR)/SOURCES
+ rpm -ba $(NAME).spec
+ if [ ! -d RPMS ] ; then mkdir -p RPMS ; fi
+ if [ ! -d SRPMS ] ; then mkdir -p SRPMS ; fi
+ cp -v $(TOPDIR)/RPMS/i386/$(NAME)-$(VERSION)-* RPMS
+ cp -v $(TOPDIR)/RPMS/i386/$(NAME)-devel-$(VERSION)-* RPMS
+ cp -v $(TOPDIR)/SRPMS/$(NAME)-$(VERSION)-* SRPMS
+
+clean:
+ rm -rf $(TOPDIR)/BUILD/$(NAME)
+ rm -rf RPMS SRPMS usr
+ rm -f $(NAME)-$(VERSION).tar.gz
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/linux/sun-nspr.spec b/src/libs/xpcom18a4/nsprpub/pkg/linux/sun-nspr.spec
new file mode 100644
index 00000000..1fed5048
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/linux/sun-nspr.spec
@@ -0,0 +1,122 @@
+Summary: Netscape Portable Runtime
+Name: %{name}
+Vendor: Sun Microsystems
+Version: %{version}
+Release: %{release}
+Copyright: MPL/GPL
+Group: System Environment/Base
+Source: %{name}-%{version}.tar.gz
+ExclusiveOS: Linux
+BuildRoot: /var/tmp/%{name}-root
+
+%description
+
+NSPR provides platform independence for non-GUI operating system
+facilities. These facilities include threads, thread synchronization,
+normal file and network I/O, interval timing and calendar time, basic
+memory management (malloc and free) and shared library linking.
+
+See: http://www.mozilla.org/projects/nspr/about-nspr.html
+
+%package devel
+Summary: Development Libraries for the Netscape Portable Runtime
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+Header files for doing development with the Netscape Portable Runtime.
+
+%prep
+%setup -c
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir $RPM_BUILD_ROOT
+cd $RPM_BUILD_ROOT
+tar xvzf $RPM_SOURCE_DIR/%{name}-%{version}.tar.gz
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+%dir /usr
+%dir /usr/lib
+%dir /usr/lib/mps
+/usr/lib/mps/libnspr4.so
+/usr/lib/mps/libplc4.so
+/usr/lib/mps/libplds4.so
+
+%files devel
+%defattr(-,root,root)
+/usr/lib/mps/libnspr4.a
+/usr/lib/mps/libplc4.a
+/usr/lib/mps/libplds4.a
+%dir /usr
+%dir /usr/include
+%dir /usr/include/mps
+%dir /usr/include/mps/nspr
+%dir /usr/include/mps/nspr/obsolete
+%dir /usr/include/mps/nspr/private
+/usr/include/mps/nspr/private/pprio.h
+/usr/include/mps/nspr/private/pprthred.h
+/usr/include/mps/nspr/private/prpriv.h
+/usr/include/mps/nspr/prcpucfg.h
+/usr/include/mps/nspr/obsolete/pralarm.h
+/usr/include/mps/nspr/obsolete/probslet.h
+/usr/include/mps/nspr/obsolete/protypes.h
+/usr/include/mps/nspr/obsolete/prsem.h
+/usr/include/mps/nspr/nspr.h
+/usr/include/mps/nspr/pratom.h
+/usr/include/mps/nspr/prbit.h
+/usr/include/mps/nspr/prclist.h
+/usr/include/mps/nspr/prcmon.h
+/usr/include/mps/nspr/prcountr.h
+/usr/include/mps/nspr/prcvar.h
+/usr/include/mps/nspr/prdtoa.h
+/usr/include/mps/nspr/prenv.h
+/usr/include/mps/nspr/prerr.h
+/usr/include/mps/nspr/prerror.h
+/usr/include/mps/nspr/prinet.h
+/usr/include/mps/nspr/prinit.h
+/usr/include/mps/nspr/prinrval.h
+/usr/include/mps/nspr/prio.h
+/usr/include/mps/nspr/pripcsem.h
+/usr/include/mps/nspr/prlink.h
+/usr/include/mps/nspr/prlock.h
+/usr/include/mps/nspr/prlog.h
+/usr/include/mps/nspr/prlong.h
+/usr/include/mps/nspr/prmem.h
+/usr/include/mps/nspr/prmon.h
+/usr/include/mps/nspr/prmwait.h
+/usr/include/mps/nspr/prnetdb.h
+/usr/include/mps/nspr/prolock.h
+/usr/include/mps/nspr/prpdce.h
+/usr/include/mps/nspr/prprf.h
+/usr/include/mps/nspr/prproces.h
+/usr/include/mps/nspr/prrng.h
+/usr/include/mps/nspr/prrwlock.h
+/usr/include/mps/nspr/prshma.h
+/usr/include/mps/nspr/prshm.h
+/usr/include/mps/nspr/prsystem.h
+/usr/include/mps/nspr/prthread.h
+/usr/include/mps/nspr/prtime.h
+/usr/include/mps/nspr/prtpool.h
+/usr/include/mps/nspr/prtrace.h
+/usr/include/mps/nspr/prtypes.h
+/usr/include/mps/nspr/prvrsion.h
+/usr/include/mps/nspr/prwin16.h
+/usr/include/mps/nspr/plarenas.h
+/usr/include/mps/nspr/plarena.h
+/usr/include/mps/nspr/plhash.h
+/usr/include/mps/nspr/plbase64.h
+/usr/include/mps/nspr/plerror.h
+/usr/include/mps/nspr/plgetopt.h
+/usr/include/mps/nspr/plresolv.h
+/usr/include/mps/nspr/plstr.h
+
+%changelog
+* Sat Jan 18 2003 Kirk Erickson <kirk.erickson@sun.com>
+- http://bugzilla.mozilla.org/show_bug.cgi?id=189501
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.com b/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.com
new file mode 100644
index 00000000..32de8a9b
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.com
@@ -0,0 +1,32 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: Makefile.com $"
+#
+
+MACH = $(shell mach)
+
+PUBLISH_ROOT = $(DIST)
+ifeq ($(MOD_DEPTH),../..)
+ROOT = ROOT
+else
+ROOT = $(subst ../../,,$(MOD_DEPTH))/ROOT
+endif
+
+PKGARCHIVE = $(dist_libdir)/pkgarchive
+DATAFILES = copyright
+FILES = $(DATAFILES) pkginfo prototype
+
+PACKAGE = $(shell basename `pwd`)
+
+PRODUCT_VERSION = $(shell grep PR_VERSION $(dist_includedir)/prinit.h \
+ | sed -e 's/"$$//' -e 's/.*"//' -e 's/ .*//')
+
+LN = /usr/bin/ln
+
+CLOBBERFILES = $(FILES)
+
+include $(topsrcdir)/config/rules.mk
+
+# vim: ft=make
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.in b/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.in
new file mode 100644
index 00000000..0c2d2e31
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.in
@@ -0,0 +1,60 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: Makefile.in $"
+#
+
+MOD_DEPTH = ../..
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+include $(MOD_DEPTH)/config/autoconf.mk
+
+%: %.ksh
+ $(RM) $@
+ cp $< $@
+ chmod +x $@
+
+ifeq ($(USE_64), 1)
+DIRS = \
+ SUNWprx
+else
+DIRS = \
+ SUNWpr
+endif
+
+PROTO = \
+ $(ROOT) \
+ $(ROOT)/usr \
+ $(ROOT)/usr/lib \
+ $(ROOT)/usr/lib/mps
+
+ifdef USE_64
+PROTO += $(ROOT)/usr/lib/mps/sparcv9
+endif
+
+include $(srcdir)/Makefile.com
+
+awk_pkginfo: bld_awk_pkginfo
+ ./bld_awk_pkginfo -m $(MACH) -p "$(PRODUCT_VERSION)" -o $@ -v $(PRODUCT_VERSION)
+
+all:: awk_pkginfo $(PROTO)
+publish: awk_pkginfo $(PROTO)
+ +$(LOOP_OVER_DIRS)
+
+clean clobber::
+ $(RM) awk_pkginfo bld_awk_pkginfo
+ $(RM) -r $(ROOT)
+
+$(ROOT) $(ROOT)/%:
+ mkdir -p $@
+
+ifdef USE_64
+$(ROOT)/usr/lib/mps/sparcv9:
+ $(LN) -sf ../../../../$(dist_libdir) $@
+else
+$(ROOT)/usr/lib/mps:
+ $(LN) -sf ../../../$(dist_libdir) $@
+endif
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.targ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.targ
new file mode 100644
index 00000000..9c49cf20
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/Makefile.targ
@@ -0,0 +1,40 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: Makefile.targ $"
+#
+
+pkginfo: pkginfo.tmpl ../awk_pkginfo
+ $(RM) $@; nawk -f ../awk_pkginfo $< > $@
+
+# we need to copy prototype_sparc to current too find copyright in current
+prototype: $(srcdir)/prototype_com $(srcdir)/prototype_$(MACH)
+ cat $(srcdir)/prototype_$(MACH) | sed -e \
+'/^!include[ ][ ]*prototype_com/ r ./prototype_com' \
+-e 's/^!include[ ][ ]*prototype_com//g' >prototype
+
+
+
+pkg: $(PKGARCHIVE) prototype
+ cp $(srcdir)/prototype_com .
+ cp $(srcdir)/prototype_$(MACH) .
+ cp $(srcdir)/depend .
+ pkgmk -f prototype_$(MACH) -d $(PKGARCHIVE) -r $(ROOT) -o $(PACKAGE)
+
+$(PKGARCHIVE):
+ [ -d $(PKGARCHIVE) ] || mkdir -p $(PKGARCHIVE)
+
+$(DATAFILES): %: $(srcdir)/../common_files/%
+ $(RM) $@; cp $(srcdir)/../common_files/$@ $@
+
+#$(MACHDATAFILES): %: $(srcdir)/../common_files/%_$(MACH)
+# $(RM) $@; cp $(srcdir)/../common_files/$@_$(MACH) $@
+#
+#$(MACHDATAFILES): %: $(srcdir)/%_$(MACH)
+# $(RM) $@; cp $(srcdir)/$@_$(MACH) $@
+
+clobber clean::
+ -$(RM) $(CLOBBERFILES) $(CLEANFILES)
+
+.PHONY: pkg
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/Makefile.in b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/Makefile.in
new file mode 100644
index 00000000..ab54db6f
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/Makefile.in
@@ -0,0 +1,22 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: Makefile.in $"
+#
+
+MOD_DEPTH = ../../..
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+include $(MOD_DEPTH)/config/autoconf.mk
+
+include $(srcdir)/../Makefile.com
+
+DATAFILES +=
+
+all:: $(FILES)
+publish:: all pkg
+
+include $(srcdir)/../Makefile.targ
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/depend b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/depend
new file mode 100644
index 00000000..57bc554e
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/depend
@@ -0,0 +1,27 @@
+# Copyright 2002 Microsystems, Inc. All Rights Reserved.
+# Use is subject to license terms.
+#
+# $Id: depend $
+#
+# This package information file defines software dependencies associated
+# with the pkg. You can define three types of pkg dependencies with this file:
+# P indicates a prerequisite for installation
+# I indicates an incompatible package
+# R indicates a reverse dependency
+# <pkg.abbr> see pkginfo(4), PKG parameter
+# <name> see pkginfo(4), NAME parameter
+# <version> see pkginfo(4), VERSION parameter
+# <arch> see pkginfo(4), ARCH parameter
+# <type> <pkg.abbr> <name>
+# (<arch>)<version>
+# (<arch>)<version>
+# ...
+# <type> <pkg.abbr> <name>
+# ...
+
+P SUNWcar Core Architecture, (Root)
+P SUNWkvm Core Architecture, (Kvm)
+P SUNWcsr Core Solaris, (Root)
+P SUNWcsu Core Solaris, (Usr)
+P SUNWcsd Core Solaris Devices
+P SUNWcsl Core Solaris Libraries
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/pkginfo.tmpl b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/pkginfo.tmpl
new file mode 100644
index 00000000..431ef37a
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/pkginfo.tmpl
@@ -0,0 +1,34 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: pkginfo.tmpl $"
+#
+#
+# This required package information file describes characteristics of the
+# package, such as package abbreviation, full package name, package version,
+# and package architecture.
+#
+PKG="SUNWpr"
+NAME="Netscape Portable Runtime"
+ARCH="ISA"
+VERSION="NSPRVERS,REV=0.0.0"
+SUNW_PRODNAME="Netscape Portable Runtime"
+SUNW_PRODVERS="NSPRVERS"
+SUNW_PKGTYPE="usr"
+MAXINST="1000"
+CATEGORY="system"
+DESC="Netscape Portable Runtime Interface"
+VENDOR="Sun Microsystems, Inc."
+HOTLINE="Please contact your local service provider"
+EMAIL=""
+CLASSES="none"
+BASEDIR=/
+SUNW_PKGVERS="1.0"
+#VSTOCK="<reserved by Release Engineering for package part #>"
+#ISTATES="<developer defined>"
+#RSTATES='<developer defined>'
+#ULIMIT="<developer defined>"
+#ORDER="<developer defined>"
+#PSTAMP="<developer defined>"
+#INTONLY="<developer defined>"
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_com b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_com
new file mode 100644
index 00000000..e92c4e51
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_com
@@ -0,0 +1,31 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: prototype_com $"
+#
+# This required package information file contains a list of package contents.
+# The 'pkgmk' command uses this file to identify the contents of a package
+# and their location on the development machine when building the package.
+# Can be created via a text editor or through use of the 'pkgproto' command.
+
+#!search <pathname pathname ...> # where to find pkg objects
+#!include <filename> # include another 'prototype' file
+#!default <mode> <owner> <group> # default used if not specified on entry
+#!<param>=<value> # puts parameter in pkg environment
+
+# packaging files
+i copyright
+i pkginfo
+i depend
+#
+# source locations relative to the prototype file
+#
+# SUNWpr
+#
+d none usr 755 root sys
+d none usr/lib 755 root bin
+d none usr/lib/mps 755 root bin
+f none usr/lib/mps/libnspr4.so 755 root bin
+f none usr/lib/mps/libplc4.so 755 root bin
+f none usr/lib/mps/libplds4.so 755 root bin
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_i386 b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_i386
new file mode 100644
index 00000000..76b92016
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_i386
@@ -0,0 +1,30 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: prototype_i386 $"
+#
+# This required package information file contains a list of package contents.
+# The 'pkgmk' command uses this file to identify the contents of a package
+# and their location on the development machine when building the package.
+# Can be created via a text editor or through use of the 'pkgproto' command.
+
+#!search <pathname pathname ...> # where to find pkg objects
+#!include <filename> # include another 'prototype' file
+#!default <mode> <owner> <group> # default used if not specified on entry
+#!<param>=<value> # puts parameter in pkg environment
+
+#
+# Include ISA independent files (prototype_com)
+#
+!include prototype_com
+#
+#
+#
+# List files which are i386 specific here
+#
+# source locations relative to the prototype file
+#
+#
+# SUNWpr
+#
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_sparc b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_sparc
new file mode 100644
index 00000000..4da58b01
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWpr/prototype_sparc
@@ -0,0 +1,33 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: prototype_sparc $"
+#
+# This required package information file contains a list of package contents.
+# The 'pkgmk' command uses this file to identify the contents of a package
+# and their location on the development machine when building the package.
+# Can be created via a text editor or through use of the 'pkgproto' command.
+
+#!search <pathname pathname ...> # where to find pkg objects
+#!include <filename> # include another 'prototype' file
+#!default <mode> <owner> <group> # default used if not specified on entry
+#!<param>=<value> # puts parameter in pkg environment
+
+#
+# Include ISA independent files (prototype_com)
+#
+!include prototype_com
+#
+#
+#
+# List files which are SPARC specific here
+#
+# source locations relative to the prototype file
+#
+#
+# SUNWpr
+#
+d none usr/lib/mps/cpu 755 root bin
+d none usr/lib/mps/cpu/sparcv8plus 755 root bin
+f none usr/lib/mps/cpu/sparcv8plus/libnspr_flt4.so 755 root bin
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/Makefile.in b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/Makefile.in
new file mode 100644
index 00000000..ab54db6f
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/Makefile.in
@@ -0,0 +1,22 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: Makefile.in $"
+#
+
+MOD_DEPTH = ../../..
+topsrcdir = @top_srcdir@
+srcdir = @srcdir@
+VPATH = @srcdir@
+
+include $(MOD_DEPTH)/config/autoconf.mk
+
+include $(srcdir)/../Makefile.com
+
+DATAFILES +=
+
+all:: $(FILES)
+publish:: all pkg
+
+include $(srcdir)/../Makefile.targ
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/depend b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/depend
new file mode 100644
index 00000000..5be1ecd9
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/depend
@@ -0,0 +1,30 @@
+# Copyright 2002 Microsystems, Inc. All Rights Reserved.
+# Use is subject to license terms.
+#
+# $Id: depend $
+#
+# This package information file defines software dependencies associated
+# with the pkg. You can define three types of pkg dependencies with this file:
+# P indicates a prerequisite for installation
+# I indicates an incompatible package
+# R indicates a reverse dependency
+# <pkg.abbr> see pkginfo(4), PKG parameter
+# <name> see pkginfo(4), NAME parameter
+# <version> see pkginfo(4), VERSION parameter
+# <arch> see pkginfo(4), ARCH parameter
+# <type> <pkg.abbr> <name>
+# (<arch>)<version>
+# (<arch>)<version>
+# ...
+# <type> <pkg.abbr> <name>
+# ...
+
+P SUNWcar Core Architecture, (Root)
+P SUNWkvm Core Architecture, (Kvm)
+P SUNWcsr Core Solaris, (Root)
+P SUNWcsu Core Solaris, (Usr)
+P SUNWcsd Core Solaris Devices
+P SUNWcsl Core Solaris Libraries
+P SUNWcarx Core Architecture, (Root) (64-bit)
+P SUNWcsxu Core Solaris (Usr) (64-bit)
+P SUNWcslx Core Solaris Libraries (64-bit)
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/pkginfo.tmpl b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/pkginfo.tmpl
new file mode 100644
index 00000000..0b13c5be
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/pkginfo.tmpl
@@ -0,0 +1,35 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: pkginfo.tmpl $"
+#
+#
+# This required package information file describes characteristics of the
+# package, such as package abbreviation, full package name, package version,
+# and package architecture.
+#
+PKG="SUNWprx"
+NAME="Netscape Portable Runtime (64-bit)"
+ARCH="ISA"
+SUNW_ISA="sparcv9"
+VERSION="NSPRVERS,REV=0.0.0"
+SUNW_PRODNAME="Netscape Portable Runtime"
+SUNW_PRODVERS="NSPRVERS"
+SUNW_PKGTYPE="usr"
+MAXINST="1000"
+CATEGORY="system"
+DESC="Netscape Portable Runtime Interface (64-bit)"
+VENDOR="Sun Microsystems, Inc."
+HOTLINE="Please contact your local service provider"
+EMAIL=""
+CLASSES="none"
+BASEDIR=/
+SUNW_PKGVERS="1.0"
+#VSTOCK="<reserved by Release Engineering for package part #>"
+#ISTATES="<developer defined>"
+#RSTATES='<developer defined>'
+#ULIMIT="<developer defined>"
+#ORDER="<developer defined>"
+#PSTAMP="<developer defined>"
+#INTONLY="<developer defined>"
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_com b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_com
new file mode 100644
index 00000000..700d61ca
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_com
@@ -0,0 +1,28 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: prototype_com $"
+#
+# This required package information file contains a list of package contents.
+# The 'pkgmk' command uses this file to identify the contents of a package
+# and their location on the development machine when building the package.
+# Can be created via a text editor or through use of the 'pkgproto' command.
+
+#!search <pathname pathname ...> # where to find pkg objects
+#!include <filename> # include another 'prototype' file
+#!default <mode> <owner> <group> # default used if not specified on entry
+#!<param>=<value> # puts parameter in pkg environment
+
+# packaging files
+i copyright
+i pkginfo
+i depend
+#
+# source locations relative to the prototype file
+#
+# SUNWprx
+#
+d none usr 755 root sys
+d none usr/lib 755 root bin
+d none usr/lib/mps 755 root bin
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_sparc b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_sparc
new file mode 100644
index 00000000..cd3da121
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/SUNWprx/prototype_sparc
@@ -0,0 +1,35 @@
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+#ident "$Id: prototype_sparc $"
+#
+# This required package information file contains a list of package contents.
+# The 'pkgmk' command uses this file to identify the contents of a package
+# and their location on the development machine when building the package.
+# Can be created via a text editor or through use of the 'pkgproto' command.
+
+#!search <pathname pathname ...> # where to find pkg objects
+#!include <filename> # include another 'prototype' file
+#!default <mode> <owner> <group> # default used if not specified on entry
+#!<param>=<value> # puts parameter in pkg environment
+
+#
+# Include ISA independent files (prototype_com)
+#
+!include prototype_com
+#
+#
+#
+# List files which are SPARC specific here
+#
+# source locations relative to the prototype file
+#
+#
+# SUNWprx
+#
+s none usr/lib/mps/64=sparcv9
+d none usr/lib/mps/sparcv9 755 root bin
+f none usr/lib/mps/sparcv9/libnspr4.so 755 root bin
+f none usr/lib/mps/sparcv9/libplc4.so 755 root bin
+f none usr/lib/mps/sparcv9/libplds4.so 755 root bin
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/bld_awk_pkginfo.ksh b/src/libs/xpcom18a4/nsprpub/pkg/solaris/bld_awk_pkginfo.ksh
new file mode 100755
index 00000000..b01645e4
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/bld_awk_pkginfo.ksh
@@ -0,0 +1,105 @@
+#!/usr/bin/ksh -p
+#
+#ident "$Id: bld_awk_pkginfo.ksh $"
+#
+# Copyright 2002 Sun Microsystems, Inc. All rights reserved.
+# Use is subject to license terms.
+#
+# Simple script which builds the awk_pkginfo awk script. This awk script
+# is used to convert the pkginfo.tmpl files into pkginfo files
+# for the build.
+#
+
+usage()
+{
+ cat <<-EOF
+usage: bld_awk_pkginfo -p <prodver> -m <mach> -o <awk_script> [-v <version>]
+EOF
+}
+
+#
+# Awk strings
+#
+# two VERSION patterns: one for Dewey decimal, one for Dewey plus ,REV=n
+# the first has one '=' the second has two or more '='
+#
+VERSION1="VERSION=[^=]*$"
+VERSION2="VERSION=[^=]*=.*$"
+PRODVERS="^SUNW_PRODVERS="
+ARCH='ARCH=\"ISA\"'
+
+#
+# parse command line
+#
+mach=""
+prodver=""
+awk_script=""
+version="NSPRVERS"
+
+while getopts o:p:m:v: c
+do
+ case $c in
+ o)
+ awk_script=$OPTARG
+ ;;
+ m)
+ mach=$OPTARG
+ ;;
+ p)
+ prodver=$OPTARG
+ ;;
+ v)
+ version=$OPTARG
+ ;;
+ \?)
+ usage
+ exit 1
+ ;;
+ esac
+done
+
+if [[ ( -z $prodver ) || ( -z $mach ) || ( -z $awk_script ) ]]
+then
+ usage
+ exit 1
+fi
+
+if [[ -f $awk_script ]]
+then
+ rm -f $awk_script
+fi
+
+#
+# Build REV= field based on date
+#
+rev=$(date "+%Y.%m.%d.%H.%M")
+
+#
+# Build awk script which will process all the
+# pkginfo.tmpl files.
+#
+# the first VERSION pattern is replaced with a leading quotation mark
+#
+rm -f $awk_script
+cat << EOF > $awk_script
+/$VERSION1/ {
+ sub(/\=[^=]*$/,"=\"$rev\"")
+ print
+ next
+ }
+/$VERSION2/ {
+ sub(/\=[^=]*$/,"=$rev\"")
+ sub(/NSPRVERS/,"$version")
+ print
+ next
+ }
+/$PRODVERS/ {
+ printf "SUNW_PRODVERS=\"%s\"\n", "$prodver"
+ next
+ }
+/$ARCH/ {
+ printf "ARCH=\"%s\"\n", "$mach"
+ next
+ }
+{ print }
+EOF
diff --git a/src/libs/xpcom18a4/nsprpub/pkg/solaris/common_files/copyright b/src/libs/xpcom18a4/nsprpub/pkg/solaris/common_files/copyright
new file mode 100644
index 00000000..1e0f6ce3
--- /dev/null
+++ b/src/libs/xpcom18a4/nsprpub/pkg/solaris/common_files/copyright
@@ -0,0 +1,28 @@
+The contents of this package are subject to the Mozilla Public License
+Version 1.1 (the "License"); you may not use this package except in
+compliance with the License. You may obtain a copy of the License at
+http://www.mozilla.org/MPL/
+
+Software distributed under the License is distributed on an "AS IS"
+basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the
+License for the specific language governing rights and limitations
+under the License.
+
+The Original Code is the Netscape Portable Runtime (NSPR).
+
+The Initial Developer of the Original Code is Netscape Communications
+Corporation. Portions created by Netscape are Copyright (C) 1998-2000
+Netscape Communications Corporation. All Rights Reserved.
+
+Contributor(s):
+
+Alternatively, the contents of this package may be used under the terms
+of the GNU General Public License Version 2 or later (the "GPL"), in
+which case the provisions of the GPL are applicable instead of those
+above. If you wish to allow use of your version of this package only
+under the terms of the GPL and not to allow others to use your version
+of this package under the MPL, indicate your decision by deleting the
+provisions above and replace them with the notice and other provisions
+required by the GPL. If you do not delete the provisions above, a
+recipient may use your version of this package under either the MPL or
+the GPL.