summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..4c9c5f6
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,16 @@
+AM_CPPFLAGS = $(XORG_CFLAGS) \
+ $(CWARNFLAGS) \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src
+
+tests = test-draglock test-bezier
+
+noinst_PROGRAMS = $(tests)
+
+test_draglock_SOURCES = test-draglock.c
+test_draglock_LDADD = ../src/libdraglock.la
+
+test_bezier_SOURCES = test-bezier.c
+test_bezier_LDADD = ../src/libbezier.la -lm
+
+TESTS = $(tests)