summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-28 08:19:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-28 08:19:11 +0000
commit70f224c227edbecc6520e0a43e0586f4a270e03b (patch)
tree2f53ba736830f7d7d29497669bd5fe74f56f766c
parentAdding Makefile. (diff)
downloadkinet-metapackages-70f224c227edbecc6520e0a43e0586f4a270e03b.tar.xz
kinet-metapackages-70f224c227edbecc6520e0a43e0586f4a270e03b.zip
Adding kinet-metapackages.7 manpage.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--man/Makefile57
-rw-r--r--man/kinet-metapackages.7.rst52
-rw-r--r--man/man.in17
3 files changed, 126 insertions, 0 deletions
diff --git a/man/Makefile b/man/Makefile
new file mode 100644
index 0000000..5d9a70f
--- /dev/null
+++ b/man/Makefile
@@ -0,0 +1,57 @@
+# Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Depends: python3-docutils
+
+RST2MAN = rst2man \
+ --no-datestamp \
+ --no-generator \
+ --strict \
+ --strip-comments \
+ --tab-width=4 \
+ --verbose
+
+VERSION := $(shell cat ../VERSION.txt)
+
+SHELL := sh -e
+
+all: build
+
+build: man
+
+rebuild: clean build
+
+man: man.in *.rst
+ @echo -n "Creating manpages... "
+
+ @for FILE in *.rst; \
+ do \
+ cp man.in $$(basename $${FILE} .rst); \
+ $(RST2MAN) $${FILE} | \
+ sed -e '/^.\\" Man page generated/d' \
+ -e '/^.\\" Generated by/d' \
+ -e "s|^\(.TH .*\) \(\"\" \"\"\) |\1 $${VERSION} kinet-metapackages |" \
+ >> $$(basename $${FILE} .rst); \
+ echo -n "."; \
+ done
+
+ @echo " done."
+
+clean:
+ rm -f *.[0-9]
+
+.PHONY: all clean build rebuild man
diff --git a/man/kinet-metapackages.7.rst b/man/kinet-metapackages.7.rst
new file mode 100644
index 0000000..fe3d342
--- /dev/null
+++ b/man/kinet-metapackages.7.rst
@@ -0,0 +1,52 @@
+.. Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+..
+.. SPDX-License-Identifier: GPL-3.0+
+..
+.. This program is free software: you can redistribute it and/or modify
+.. it under the terms of the GNU General Public License as published by
+.. the Free Software Foundation, either version 3 of the License, or
+.. (at your option) any later version.
+..
+.. This program is distributed in the hope that it will be useful,
+.. but WITHOUT ANY WARRANTY; without even the implied warranty of
+.. MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.. GNU General Public License for more details.
+..
+.. You should have received a copy of the GNU General Public License
+.. along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+==================
+kinet-metapackages
+==================
+
+-------------------------------------------
+Package selection for Gymnasium Kirchenfeld
+-------------------------------------------
+
+:manual section: 7
+:manual group: Kinet
+
+Description
+===========
+
+Gymnasium Kirchenfeld uses Debian-based images and systems.
+
+The following main metapackages are available:
+
+kinet-base-system
+-----------------
+
+| The Kinet Base System includes packages that provide a reasonably
+| small but not too limited character-mode system.
+
+kinet-container-server
+----------------------
+
+| The Kinet Container Server is a complete system configured as a
+| server for systemd-nspawn based containers.
+
+Authors
+=======
+
+kinet-metapackages were written by Daniel Baumann
+<daniel.baumann@progress-linux.org> and others.
diff --git a/man/man.in b/man/man.in
new file mode 100644
index 0000000..44e6655
--- /dev/null
+++ b/man/man.in
@@ -0,0 +1,17 @@
+.\" Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+.\"
+.\" SPDX-License-Identifier: GPL-3.0+
+.\"
+.\" This program is free software: you can redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as published by
+.\" the Free Software Foundation, either version 3 of the License, or
+.\" (at your option) any later version.
+.\"
+.\" This program is distributed in the hope that it will be useful,
+.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License
+.\" along with this program. If not, see <https://www.gnu.org/licenses/>.
+.\"