summaryrefslogtreecommitdiffstats
path: root/bin/git-debian-check.d/packaging_debian-upload-urgency.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bin/git-debian-check.d/packaging_debian-upload-urgency.sh')
-rwxr-xr-xbin/git-debian-check.d/packaging_debian-upload-urgency.sh48
1 files changed, 48 insertions, 0 deletions
diff --git a/bin/git-debian-check.d/packaging_debian-upload-urgency.sh b/bin/git-debian-check.d/packaging_debian-upload-urgency.sh
new file mode 100755
index 0000000..8ee731f
--- /dev/null
+++ b/bin/git-debian-check.d/packaging_debian-upload-urgency.sh
@@ -0,0 +1,48 @@
+#!/bin/sh
+
+# source-tools - Git extra utilities
+# Copyright (C) 2014-2016 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+set -e
+
+echo -n " * (\033[0;32m${FEATURE_BRANCH}\033[0m) debian upload urgency..."
+
+DERIVATIVE_TAGS="$(git tag | grep "^${FEATURE_BRANCH}" | awk -F/ '{ print $2 }')"
+
+for DERIVATIVE_TAG in ${DERIVATIVE_TAGS}
+do
+ DERIVATIVE_URGENCY="$(git show ${FEATURE_BRANCH}/${DERIVATIVE_TAG}:debian/changelog | head -n1 | awk -Furgency= '{ print $2 }' | sed -e 's| ||g')"
+ DISTRIBUTION="$(git show ${FEATURE_BRANCH}/${DERIVATIVE_TAG}:debian/changelog | head -n1 | awk '{ print $3 }' | sed -e 's|;$||')"
+
+ case "${DISTRIBUTION}" in
+ *-extras)
+ URGENCY="low"
+ ;;
+
+ *)
+ TAG="$(echo ${DERIVATIVE_TAG} | sed -e 's|-0+cairon[0-9]$||' -e 's|-0_cairon[0-9]$||' -e 's|-0cairon[0-9]$||' -e 's|_cairon[0-9]$||' -e 's|cairon[0-9]$||')"
+ URGENCY="$(git show debian/${TAG}:debian/changelog | head -n1 | awk -Furgency= '{ print $2 }' | sed -e 's| ||g')"
+ ;;
+ esac
+
+ if [ "${DERIVATIVE_URGENCY}" != "${URGENCY}" ]
+ then
+ echo " \033[1;31mno\033[0m."
+ echo "E: wrong urgency of ${DERIVATIVE_TAG}, should be ${URGENCY} instead of ${DERIVATIVE_URGENCY}."
+ fi
+done
+
+echo " \033[1;32myes\033[0m."