summaryrefslogtreecommitdiffstats
path: root/bin/git-debian-check.d/packaging_debian-vcs-fields.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bin/git-debian-check.d/packaging_debian-vcs-fields.sh')
-rwxr-xr-xbin/git-debian-check.d/packaging_debian-vcs-fields.sh35
1 files changed, 35 insertions, 0 deletions
diff --git a/bin/git-debian-check.d/packaging_debian-vcs-fields.sh b/bin/git-debian-check.d/packaging_debian-vcs-fields.sh
new file mode 100755
index 0000000..476a947
--- /dev/null
+++ b/bin/git-debian-check.d/packaging_debian-vcs-fields.sh
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+# source-tools - Git extra utilities
+# Copyright (C) 2014-2016 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+set -e
+
+echo -n " * (\033[0;32m${FEATURE_BRANCH}\033[0m) debian vcs fields..."
+
+if ! grep -qs "^Vcs-Browser: ${VCS_BROWSER}/${REPOSITORY}.git" debian/control
+then
+ echo " \033[1;31mno\033[0m."
+ echo "E: packaging has no vcs-browser field."
+fi
+
+if ! grep -qs "Vcs-Git: ${VCS_GIT}/${REPOSITORY}.git" debian/control
+then
+ echo " \033[1;31mno\033[0m."
+ echo "E: packaging has no vcs-git field."
+fi
+
+echo " \033[1;32myes\033[0m."