summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml20
1 files changed, 13 insertions, 7 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index bdfb5ab..8a31d2b 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -5,7 +5,7 @@ files: ^(anta|docs|scripts|tests|asynceapi)/
repos:
- repo: https://github.com/pre-commit/pre-commit-hooks
- rev: v4.4.0
+ rev: v4.6.0
hooks:
- id: trailing-whitespace
exclude: docs/.*.svg
@@ -15,7 +15,7 @@ repos:
- id: check-merge-conflict
- repo: https://github.com/Lucas-C/pre-commit-hooks
- rev: v1.5.4
+ rev: v1.5.5
hooks:
- name: Check and insert license on Python files
id: insert-license
@@ -43,7 +43,7 @@ repos:
- '<!--| ~| -->'
- repo: https://github.com/astral-sh/ruff-pre-commit
- rev: v0.4.2
+ rev: v0.4.8
hooks:
- id: ruff
name: Run Ruff linter
@@ -51,11 +51,10 @@ repos:
- id: ruff-format
name: Run Ruff formatter
- - repo: local # as per https://pylint.pycqa.org/en/latest/user_guide/installation/pre-commit-integration.html
+ - repo: https://github.com/pycqa/pylint
+ rev: "v3.2.3"
hooks:
- id: pylint
- entry: pylint
- language: python
name: Check code style with pylint
description: This hook runs pylint.
types: [python]
@@ -63,9 +62,16 @@ repos:
- -rn # Only display messages
- -sn # Don't display the score
- --rcfile=pyproject.toml # Link to config file
+ additional_dependencies:
+ - anta[cli]
+ - types-PyYAML
+ - types-requests
+ - types-pyOpenSSL
+ - pylint_pydantic
+ - pytest
- repo: https://github.com/codespell-project/codespell
- rev: v2.2.6
+ rev: v2.3.0
hooks:
- id: codespell
name: Checks for common misspellings in text files.