summaryrefslogtreecommitdiffstats
path: root/.vscode/settings.json
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--.vscode/settings.json25
1 files changed, 5 insertions, 20 deletions
diff --git a/.vscode/settings.json b/.vscode/settings.json
index dd63eea..d50caa1 100644
--- a/.vscode/settings.json
+++ b/.vscode/settings.json
@@ -1,29 +1,14 @@
{
"ruff.enable": true,
- "python.testing.unittestEnabled": false,
+ "ruff.configuration": "pyproject.toml",
"python.testing.pytestEnabled": true,
- "pylint.importStrategy": "fromEnvironment",
- "pylint.severity": {
- "refactor": "Warning"
- },
- "pylint.args": [
- "--load-plugins",
- "pylint_pydantic",
- "--rcfile=pyproject.toml"
- ],
"python.testing.pytestArgs": [
"tests"
],
- "autoDocstring.docstringFormat": "numpy",
- "autoDocstring.includeName": false,
- "autoDocstring.includeExtendedSummary": true,
- "autoDocstring.startOnNewLine": true,
- "autoDocstring.guessTypes": true,
- "python.languageServer": "Pylance",
"githubIssues.issueBranchTitle": "issues/${issueNumber}-${issueTitle}",
- "editor.formatOnPaste": true,
- "files.trimTrailingWhitespace": true,
- "mypy.configFile": "pyproject.toml",
- "workbench.remoteIndicator.showExtensionRecommendations": true,
+ "pylint.importStrategy": "fromEnvironment",
+ "pylint.args": [
+ "--rcfile=pyproject.toml"
+ ],
} \ No newline at end of file