summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pyproject.toml23
1 files changed, 15 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0c7a915..49f699d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -5,14 +5,16 @@ build-backend = "setuptools.build_meta"
[project]
name = "anta"
-version = "v0.15.0"
+version = "v1.0.0"
readme = "docs/README.md"
-authors = [{ name = "Khelil Sator", email = "ksator@arista.com" }]
+authors = [{ name = "Arista Networks ANTA maintainers", email = "anta-dev@arista.com" }]
maintainers = [
+ { name = "Arista Networks ANTA maintainers", email = "anta-dev@arista.com" },
{ name = "Khelil Sator", email = "ksator@arista.com" },
{ name = "Matthieu Tâche", email = "mtache@arista.com" },
{ name = "Thomas Grimonet", email = "tgrimonet@arista.com" },
{ name = "Guillaume Mulocher", email = "gmulocher@arista.com" },
+ { name = "Carl Baillargeon", email = "carl.baillargeon@arista.com" },
]
description = "Arista Network Test Automation (ANTA) Framework"
license = { file = "LICENSE" }
@@ -33,7 +35,7 @@ keywords = ["test", "anta", "Arista", "network", "automation", "networking", "de
classifiers = [
"License :: OSI Approved :: Apache Software License",
"Operating System :: OS Independent",
- "Development Status :: 4 - Beta",
+ "Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"Intended Audience :: System Administrators",
"Intended Audience :: Information Technology",
@@ -57,7 +59,7 @@ cli = [
]
dev = [
"bumpver>=2023.1129",
- "codespell~=2.2.6",
+ "codespell>=2.2.6,<2.4.0",
"mypy-extensions~=1.0",
"mypy~=1.10",
"pre-commit>=3.3.3",
@@ -89,12 +91,13 @@ doc = [
"mkdocs-material>=8.3.9",
"mkdocs>=1.3.1",
"mkdocstrings[python]>=0.20.0",
+ "mkdocs-glightbox>=0.4.0"
]
[project.urls]
-Homepage = "https://www.anta.ninja"
-"Bug Tracker" = "https://github.com/arista-netdevops-community/anta/issues"
-Contributing = "https://www.anta.ninja/main/contribution/"
+Homepage = "https://anta.arista.com"
+"Bug Tracker" = "https://github.com/aristanetworks/anta/issues"
+Contributing = "https://anta.arista.com/main/contribution/"
[project.scripts]
anta = "anta.cli:cli"
@@ -110,7 +113,7 @@ namespaces = false
# Version
################################
[tool.bumpver]
-current_version = "0.15.0"
+current_version = "1.0.0"
version_pattern = "MAJOR.MINOR.PATCH"
commit_message = "bump: Version {old_version} -> {new_version}"
commit = true
@@ -396,6 +399,10 @@ runtime-evaluated-base-classes = ["pydantic.BaseModel", "anta.models.AntaTest.In
"C901", # TODO: test function is too complex, needs a refactor
"PLR0911", # TODO: Too many return statements, same as above needs a refactor
]
+"anta/tests/routing/isis.py" = [
+ "C901", # TODO: test function is too complex, needs a refactor
+ "PLR0912" # Too many branches (15/12) (too-many-branches), needs a refactor
+]
"anta/decorators.py" = [
"ANN401", # Ok to use Any type hint in our decorators
]