summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-27 02:25:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-27 02:32:49 +0000
commit45b68b5e89e82c8237a5b028f7c1596a905f95fe (patch)
treee5d074f2da0bd432f31e1dfb4bffe8100ac90075 /debian/rules
parentUpdating to standards version 4.6.0. (diff)
downloadck-45b68b5e89e82c8237a5b028f7c1596a905f95fe.tar.xz
ck-45b68b5e89e82c8237a5b028f7c1596a905f95fe.zip
Fixing baseline violations on armel and i386, thanks to Adrian Bunk <bunk@debian.org> (Closes: #993010).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index ee6a3be..e8da4e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,12 @@
include /usr/share/dpkg/architecture.mk
-ifeq ($(DEB_BUILD_ARCH),armel)
- PLATFORM = --platform=armv7l
+ifneq (,$(filter $(DEB_HOST_ARCH), armel x32))
+ PLATFORM = --platform=unknown
+endif
+
+ifeq ($(DEB_HOST_ARCH), i386)
+ PLATFORM = --disable-sse
endif
%:
@@ -16,7 +20,7 @@ override_dh_auto_configure:
--includedir=/usr/include \
--mandir=/usr/share/man \
--cores=2 \
- --disable-sse $(PLATFORM)
+ $(PLATFORM)
override_dh_auto_test:
$(MAKE) -j1 check