summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..468baa9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+PLATFORM :=
+$(call lazy,DEB_HOST_ARCH,$$(shell dpkg-architecture -qDEB_HOST_ARCH))
+ifneq (,$(findstring armhf,$(DEB_HOST_ARCH)))
+ PLATFORM += --platform=armv7l
+endif
+
+override_dh_auto_configure:
+ ./configure \
+ --includedir=/usr/include \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --cores=2 \
+ --disable-sse \
+ $(PLATFORM)
+
+override_dh_auto_test:
+ make -j1 check
+
+%:
+ dh $@
+
+# The build target must not be empty. Sadly because of how make
+# works, we have do duplicate the target in this case.
+build:
+ dh $@
+
+.PHONY: build
+