summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-02 07:58:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-02 07:58:40 +0000
commit4ababfe2ca0eb0cc924b750f52d884f91e3a232f (patch)
treea2ccb135e231250bdce430c06c25e9642aea900a /Makefile.in
parentAdding upstream version 1.13. (diff)
downloadclzip-4ababfe2ca0eb0cc924b750f52d884f91e3a232f.tar.xz
clzip-4ababfe2ca0eb0cc924b750f52d884f91e3a232f.zip
Adding upstream version 1.14~rc1.upstream/1.14_rc1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 5f77295..55e2bcb 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -29,6 +29,10 @@ main.o : main.c
%.o : %.c
$(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
+# prevent 'make' from trying to remake source files
+$(VPATH)/configure $(VPATH)/Makefile.in $(VPATH)/doc/$(pkgname).texi : ;
+%.h %.c : ;
+
$(objs) : Makefile
carg_parser.o : carg_parser.h
decoder.o : lzip.h decoder.h
@@ -39,13 +43,12 @@ list.o : lzip.h lzip_index.h
lzip_index.o : lzip.h lzip_index.h
main.o : carg_parser.h lzip.h decoder.h encoder_base.h encoder.h fast_encoder.h
-
doc : info man
info : $(VPATH)/doc/$(pkgname).info
$(VPATH)/doc/$(pkgname).info : $(VPATH)/doc/$(pkgname).texi
- cd $(VPATH)/doc && makeinfo $(pkgname).texi
+ cd $(VPATH)/doc && $(MAKEINFO) $(pkgname).texi
man : $(VPATH)/doc/$(progname).1
@@ -127,6 +130,8 @@ dist : doc
$(DISTNAME)/testsuite/test.txt \
$(DISTNAME)/testsuite/fox.lz \
$(DISTNAME)/testsuite/fox_*.lz \
+ $(DISTNAME)/testsuite/fox6.lz \
+ $(DISTNAME)/testsuite/fox6_mark.lz \
$(DISTNAME)/testsuite/test.txt.lz \
$(DISTNAME)/testsuite/test_em.txt.lz
rm -f $(DISTNAME)