summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-16 13:46:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-16 13:46:28 +0000
commite553507c3f4eafcd26e9083fd19a87e8c9850b65 (patch)
treef0b9e7491f7f920ffa15c7f28dc50a25db87ee7c /setup.py
parentAdding upstream version 2.2.0. (diff)
downloadcolorclass-e553507c3f4eafcd26e9083fd19a87e8c9850b65.tar.xz
colorclass-e553507c3f4eafcd26e9083fd19a87e8c9850b65.zip
Adding upstream version 2.2.2.upstream/2.2.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py63
1 files changed, 0 insertions, 63 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 3f22821..0000000
--- a/setup.py
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/usr/bin/env python
-"""Setup script for the project."""
-
-from __future__ import print_function
-
-import codecs
-import os
-
-from setuptools import setup
-
-
-def readme():
- """Try to read README.rst or return empty string if failed.
-
- :return: File contents.
- :rtype: str
- """
- path = os.path.realpath(os.path.join(os.path.dirname(__file__), 'README.rst'))
- handle = None
- try:
- handle = codecs.open(path, encoding='utf-8')
- return handle.read(131072)
- except IOError:
- return ''
- finally:
- getattr(handle, 'close', lambda: None)()
-
-
-setup(
- author='@Robpol86',
- author_email='robpol86@gmail.com',
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Console',
- 'Environment :: MacOS X',
- 'Environment :: Win32 (MS Windows)',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: MacOS :: MacOS X',
- 'Operating System :: Microsoft :: Windows',
- 'Operating System :: POSIX :: Linux',
- 'Operating System :: POSIX',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Topic :: Software Development :: Libraries',
- 'Topic :: Terminals',
- 'Topic :: Text Processing :: Markup',
- ],
- description='Colorful worry-free console applications for Linux, Mac OS X, and Windows.',
- install_requires=[],
- keywords='Shell Bash ANSI ASCII terminal console colors automatic',
- license='MIT',
- long_description=readme(),
- name='colorclass',
- packages=['colorclass'],
- url='https://github.com/Robpol86/colorclass',
- version='2.2.0',
- zip_safe=True,
-)