summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 05:27:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 05:27:13 +0000
commit82f632622e56a7487a6907d824b428b09c660e3d (patch)
tree33ee2b69ff98a267395bc76624842be276727ac6 /setup.py
parentReleasing debian version 1.3.2+dfsg-1. (diff)
downloadcvprac-82f632622e56a7487a6907d824b428b09c660e3d.tar.xz
cvprac-82f632622e56a7487a6907d824b428b09c660e3d.zip
Merging upstream version 1.4.0+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--setup.py11
1 files changed, 8 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8c2c06b..ddb6654 100644
--- a/setup.py
+++ b/setup.py
@@ -100,8 +100,13 @@ setup(
# Specify the Python versions you support here. In particular, ensure
# that you indicate whether you support Python 2, Python 3 or both.
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
+ 'Programming Language :: Python :: 3.12',
],
# What does your project relate to?
@@ -111,7 +116,7 @@ setup(
# your project is installed. For an analysis of "install_requires" vs pip's
# requirements files see:
# https://packaging.python.org/en/latest/requirements.html
- install_requires=['requests[socks]>=2.27.0'],
+ install_requires=['requests[socks]>=2.27.0', 'packaging>=23.2'],
# List additional groups of dependencies here (e.g. development
# dependencies). You can install these using the following syntax,