diff options
Diffstat (limited to '')
-rw-r--r-- | setup.py | 11 |
1 files changed, 8 insertions, 3 deletions
@@ -100,8 +100,13 @@ setup( # Specify the Python versions you support here. In particular, ensure # that you indicate whether you support Python 2, Python 3 or both. - 'Programming Language :: Python :: 2', - 'Programming Language :: Python :: 2.7', + 'Programming Language :: Python :: 3 :: Only', + 'Programming Language :: Python :: 3.7', + 'Programming Language :: Python :: 3.8', + 'Programming Language :: Python :: 3.9', + 'Programming Language :: Python :: 3.10', + 'Programming Language :: Python :: 3.11', + 'Programming Language :: Python :: 3.12', ], # What does your project relate to? @@ -111,7 +116,7 @@ setup( # your project is installed. For an analysis of "install_requires" vs pip's # requirements files see: # https://packaging.python.org/en/latest/requirements.html - install_requires=['requests[socks]>=2.27.0'], + install_requires=['requests[socks]>=2.27.0', 'packaging>=23.2'], # List additional groups of dependencies here (e.g. development # dependencies). You can install these using the following syntax, |