summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-08-14 08:22:47 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-08-14 08:31:19 +0000
commit2630e3f7ff6ee5f9d0ea7454d382426a843c0ad7 (patch)
tree38c2e349b5735be1b17bcc659088725cb204257e /debian/rules
parentReleasing debian version 2.1.2~dev0+20230529-3. (diff)
downloaddeluge-2630e3f7ff6ee5f9d0ea7454d382426a843c0ad7.tar.xz
deluge-2630e3f7ff6ee5f9d0ea7454d382426a843c0ad7.zip
Manually removing some files that pybuild doesn't clean up during build (Closes: #1044344).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 8f33b31..cac3bd5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,12 @@ VERSION := $(shell dpkg-parsechangelog -SVersion | sed -e 's|~dev|.dev|' -e 's|+
execute_after_dh_auto_clean:
rm -f RELEASE-VERSION
+ # help pybuild
+ for ITEM in $$(find . -type d -name "*.egg-info" -or -type f -name "*.egg"); \
+ do \
+ rm -rf "$${ITEM}"; \
+ done
+
execute_before_dh_auto_build:
echo "$(VERSION)" > RELEASE-VERSION