summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-24 17:38:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-24 17:38:25 +0000
commitd269eb36c8f4d05fb0f8e9b8a00998dd41f0c829 (patch)
tree4268cb5c733a3b88e7c5b765a30f5b9fd81c804e /pyproject.toml
parentAdding upstream version 2.1.1. (diff)
downloaddeluge-d269eb36c8f4d05fb0f8e9b8a00998dd41f0c829.tar.xz
deluge-d269eb36c8f4d05fb0f8e9b8a00998dd41f0c829.zip
Adding upstream version 2.1.2~dev0+20230529.upstream/2.1.2_dev0+20230529
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 67ebe0a..0449619 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -9,3 +9,22 @@ skip-string-normalization = true
[tool.isort]
profile = "black"
+
+[tool.pytest.ini_options]
+# Hide logged warnings and errors in test output.
+log_cli_level = "CRITICAL"
+addopts = "--basetemp=_pytest_temp"
+markers = [
+ "todo: Tests that are yet to be written",
+ "gtkui: Tests for GTK code",
+ "security: Security related tests",
+ "slow: Tests that are particularly slow",
+ "internet: Tests that require internet connectivity",
+]
+filterwarnings = [
+ "ignore::DeprecationWarning:gi",
+ "ignore::DeprecationWarning:twisted.internet.gireactor",
+ "ignore:twisted.web.resource.*:DeprecationWarning",
+ "ignore:Using readBody.*:DeprecationWarning",
+ "ignore:resume_data is deprecated.*:DeprecationWarning:deluge.core.alertmanager",
+]