summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 11:13:02 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 11:13:02 +0000
commitee2c449056c1ab2101cccc3fdb2f94f334fdf82c (patch)
tree7d84acb9870f1b9b5bc7b9063114ec9ce4dc06ae /pyproject.toml
parentAdding upstream version 2.1.2~dev0+20230918. (diff)
downloaddeluge-ee2c449056c1ab2101cccc3fdb2f94f334fdf82c.tar.xz
deluge-ee2c449056c1ab2101cccc3fdb2f94f334fdf82c.zip
Adding upstream version 2.1.2~dev0+20231127.upstream/2.1.2_dev0+20231127
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0449619..169561f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,8 +1,5 @@
[build-system]
-requires = [
- "setuptools",
- "wheel",
-]
+requires = ["setuptools", "wheel"]
[tool.black]
skip-string-normalization = true
@@ -11,6 +8,8 @@ skip-string-normalization = true
profile = "black"
[tool.pytest.ini_options]
+# Dump tracebacks if a test takes longer than X seconds
+faulthandler_timeout = 60
# Hide logged warnings and errors in test output.
log_cli_level = "CRITICAL"
addopts = "--basetemp=_pytest_temp"