summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules34
1 files changed, 20 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index f769106..632ca11 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,29 +1,35 @@
#!/usr/bin/make -f
-export PYBUILD_DISABLE=test
+
+SHELL := sh -e
%:
- dh $@ --with python3 --buildsystem=pybuild
+ dh ${@} --buildsystem=pybuild --with=python3
+
+execute_after_dh_auto_test:
+ find . -type d -name '*.egg-info' | xargs rm -rf
+ find . -type d -name '.eggs' | xargs rm -rf
+ find . -type d -wholename './deluge/plugins/*/build' | xargs rm -rf
+
+ rm -f deluge/data/share/applications/deluge.desktop
override_dh_auto_build:
python3 setup.py build
+override_dh_auto_test:
+ # disabled
+
override_dh_auto_install:
python3 setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
- set -ex; \
+
cd debian/tmp/usr/lib/python*/*-packages/deluge/plugins/; \
- for egg in *.egg; do \
- mkdir -p $${egg%-py?.*}.egg; \
- unzip $$egg -d $${egg%-py?.*}.egg; \
- rm -f $$egg; \
+ for EGG in *.egg; \
+ do \
+ mkdir -p $${EGG%-py?.*}.egg; \
+ unzip $${EGG} -d $${EGG%-py?.*}.egg; \
+ rm -f $${EGG}; \
done
- find . -type d -name '__pycache__' | xargs rm -rf
-override_dh_auto_clean:
- dh_auto_clean
- find . -type d -name '*.egg-info' | xargs rm -rf
- find . -type d -name '.eggs' | xargs rm -rf
- find . -type d -wholename './deluge/plugins/*/build' | xargs rm -rf
- rm -f deluge/data/share/applications/deluge.desktop
+ find . -type d -name '__pycache__' | xargs rm -rf
override_dh_gencontrol:
dh_gencontrol -- $(SUBSTVARS)