summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-18 12:43:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-18 12:43:06 +0000
commit04fa95b621e5c217f982a5593bf4f6695d6ce956 (patch)
tree4058f5a44f3c4583b31ffe7e95111375dc85fcac
parentAdding upstream version 2.1.1. (diff)
downloaddnscap-04fa95b621e5c217f982a5593bf4f6695d6ce956.tar.xz
dnscap-04fa95b621e5c217f982a5593bf4f6695d6ce956.zip
Adding upstream version 2.1.2.upstream/2.1.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xconfigure20
-rw-r--r--configure.ac2
-rw-r--r--plugins/anonaes128/anonaes128.c9
-rw-r--r--plugins/cryptopan/cryptopan.c9
-rw-r--r--src/tcpstate.c11
5 files changed, 36 insertions, 15 deletions
diff --git a/configure b/configure
index b03e668..7478dfd 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for dnscap 2.1.1.
+# Generated by GNU Autoconf 2.69 for dnscap 2.1.2.
#
# Report bugs to <dnscap-users@dns-oarc.net>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='dnscap'
PACKAGE_TARNAME='dnscap'
-PACKAGE_VERSION='2.1.1'
-PACKAGE_STRING='dnscap 2.1.1'
+PACKAGE_VERSION='2.1.2'
+PACKAGE_STRING='dnscap 2.1.2'
PACKAGE_BUGREPORT='dnscap-users@dns-oarc.net'
PACKAGE_URL='https://github.com/DNS-OARC/dnscap/issues'
@@ -1353,7 +1353,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures dnscap 2.1.1 to adapt to many kinds of systems.
+\`configure' configures dnscap 2.1.2 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1424,7 +1424,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of dnscap 2.1.1:";;
+ short | recursive ) echo "Configuration of dnscap 2.1.2:";;
esac
cat <<\_ACEOF
@@ -1556,7 +1556,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-dnscap configure 2.1.1
+dnscap configure 2.1.2
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1979,7 +1979,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by dnscap $as_me 2.1.1, which was
+It was created by dnscap $as_me 2.1.2, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2842,7 +2842,7 @@ fi
# Define the identity of the package.
PACKAGE='dnscap'
- VERSION='2.1.1'
+ VERSION='2.1.2'
cat >>confdefs.h <<_ACEOF
@@ -15015,7 +15015,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by dnscap $as_me 2.1.1, which was
+This file was extended by dnscap $as_me 2.1.2, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -15082,7 +15082,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-dnscap config.status 2.1.1
+dnscap config.status 2.1.2
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index b3c5657..de16a23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@
# POSSIBILITY OF SUCH DAMAGE.
AC_PREREQ(2.61)
-AC_INIT([dnscap], [2.1.1], [dnscap-users@dns-oarc.net], [dnscap], [https://github.com/DNS-OARC/dnscap/issues])
+AC_INIT([dnscap], [2.1.2], [dnscap-users@dns-oarc.net], [dnscap], [https://github.com/DNS-OARC/dnscap/issues])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AC_CONFIG_SRCDIR([src/dnscap.c])
AC_CONFIG_HEADER([src/config.h])
diff --git a/plugins/anonaes128/anonaes128.c b/plugins/anonaes128/anonaes128.c
index 56c8656..b2d8dbd 100644
--- a/plugins/anonaes128/anonaes128.c
+++ b/plugins/anonaes128/anonaes128.c
@@ -198,7 +198,14 @@ void anonaes128_getopt(int* argc, char** argv[])
}
if (!EVP_CipherInit_ex(ctx, EVP_aes_128_ecb(), NULL, key, iv, decrypt ? 0 : 1)) {
unsigned long e = ERR_get_error();
- fprintf(stderr, "%s:%s:%s", ERR_lib_error_string(e), ERR_func_error_string(e), ERR_reason_error_string(e));
+ fprintf(stderr, "%s:%s:%s\n",
+ ERR_lib_error_string(e),
+#if OPENSSL_VERSION_NUMBER < 0x30000000L
+ ERR_func_error_string(e),
+#else
+ "",
+#endif
+ ERR_reason_error_string(e));
usage("unable to initialize AES128 cipher");
}
EVP_CIPHER_CTX_set_padding(ctx, 0);
diff --git a/plugins/cryptopan/cryptopan.c b/plugins/cryptopan/cryptopan.c
index 14f185f..5eb54c7 100644
--- a/plugins/cryptopan/cryptopan.c
+++ b/plugins/cryptopan/cryptopan.c
@@ -228,7 +228,14 @@ void cryptopan_getopt(int* argc, char** argv[])
}
if (!EVP_CipherInit_ex(ctx, EVP_aes_128_ecb(), NULL, key, iv, 1)) {
unsigned long e = ERR_get_error();
- fprintf(stderr, "%s:%s:%s\n", ERR_lib_error_string(e), ERR_func_error_string(e), ERR_reason_error_string(e));
+ fprintf(stderr, "%s:%s:%s\n",
+ ERR_lib_error_string(e),
+#if OPENSSL_VERSION_NUMBER < 0x30000000L
+ ERR_func_error_string(e),
+#else
+ "",
+#endif
+ ERR_reason_error_string(e));
usage("unable to initialize AES128 cipher");
}
EVP_CIPHER_CTX_set_padding(ctx, 0);
diff --git a/src/tcpstate.c b/src/tcpstate.c
index fce5ba1..5bc3840 100644
--- a/src/tcpstate.c
+++ b/src/tcpstate.c
@@ -77,6 +77,8 @@ tcpstate_ptr tcpstate_find(iaddr from, iaddr to, unsigned sport, unsigned dport,
return tcpstate;
}
+tcpstate_ptr _curr_tcpstate = 0;
+
tcpstate_ptr tcpstate_new(iaddr from, iaddr to, unsigned sport, unsigned dport)
{
tcpstate_ptr tcpstate = calloc(1, sizeof *tcpstate);
@@ -87,6 +89,13 @@ tcpstate_ptr tcpstate_new(iaddr from, iaddr to, unsigned sport, unsigned dport)
tcpstate = TAIL(tcpstates);
assert(tcpstate != NULL);
UNLINK(tcpstates, tcpstate, link);
+ if (tcpstate->reasm) {
+ tcpreasm_free(tcpstate->reasm);
+ }
+ if (_curr_tcpstate == tcpstate) {
+ _curr_tcpstate = 0;
+ }
+ memset(tcpstate, 0, sizeof(*tcpstate));
} else {
tcpstate_count++;
}
@@ -99,8 +108,6 @@ tcpstate_ptr tcpstate_new(iaddr from, iaddr to, unsigned sport, unsigned dport)
return tcpstate;
}
-tcpstate_ptr _curr_tcpstate = 0;
-
tcpstate_ptr tcpstate_getcurr(void)
{
return _curr_tcpstate;